6

Motivation: In an appplication I'm using, Alt+Shift+R is taken up by -- well, never mind what, something app-specific. However, on my Linux system (Kubuntu 12.04 specifically), when I press Alt+Shift without depressing any of these two keys, the keyboard layout changes.

Question: How can I make the keyboard layout change in X only take place if I depress Alt and Shift, but not if I press another key before depressing them? So that Alt+Shift+R only affects the application in my example?

5
  • Have you found the solution?
    – madhead
    May 26, 2016 at 23:23
  • @madhead: Unfortunately not. If I had a lot more reputation I might have offered a bounty. Although... I've learned to tolerate it for lack of an alternative.
    – einpoklum
    Jun 20, 2016 at 20:28
  • after a quick googling it seems to me that it is a fundamental issue somewhere in XKB (or whatever they use). So, I've switched to Alt + Caps which is almost the same as Alt + Shift and isn't used in other places.
    – madhead
    Jun 20, 2016 at 22:21
  • @madhead, a newer question linked to this one and seems to have come to a similar conclusion as you did. Your workaround could be useful to others with the same problem. Consider posting it as an answer.
    – fixer1234
    Apr 17, 2017 at 18:06
  • @madhead: It's really not almost the same, it's quite different, and what's more important - it's uncommon and surprising to others :-(
    – einpoklum
    Apr 17, 2017 at 19:06

1 Answer 1

1

Possible workaround

Go in Settings -> Text Entry. Change the keyboard shortcut from Super+Space to something else (ex. Ctrl+Space).

Good luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.