0

On a centos 6.5 machine I wanted to create a general user, where its home directory is shared among many users, called shareduser

/home/shareduser has mod 700 Then the shared folder is called: /home/shareduser/storage has the mod 777 with owner and group = shareduser further selinux is disabled

Whenever I'm cd with my own user(moataz) into the folder I get permission denied

any ideas? Cheers,

  • This is the expected behavior if /home/shareduser has mode 700. It should be 710 if you want to be able to cd to any subdirectory. – user55325 Jan 8 '14 at 17:19
0

The mod 700 means only the owner of /home/shareduser can read/write/execute (I forget what execute means wrt. directories). From the wiki page on chmod, it looks like you, at minimum, want the execute bit set on the group flags, but you also have to make sure that all related users are assigned to the group assigned to /home/shareduser (see chown) so that they can recurse within it.

0

You can change SELinux. This may solve your problem to set 'Permissive' or '0'(zero). $ setenforce [Permissive|0]

To make changes persistent through a system reboot, edit the 'SELINUX=' line in /etc/selinux/config for either 'enforcing', 'permissive', or 'disabled'. For example: SELINUX=permissive

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.