18

I've resized my C:\ partition but now I can't boot anymore. I tried to use CHKDSK to analyse the disk but keep getting this error:

CHKDSK does not support RAW disk.

I suppose the partition is damaged or changed to RAW format. So, how can I restore it to NTFS or at least recover my data?

1
14

Didn't need to recover my data and reinstall Windows. I've repaired the damaged partition unsing a recovery tool TestDisk.

  1. Analyse hard disk and find the damaged partition;
  2. Change it to primary partition;
  3. Rewrite the partition table to register it again;
  4. Reboot, Windows starts normally.

All these steps are explained here: Step_By_Step Wiki

5

Just in case this helps someone else in a slightly different scenario, chkdsk /F worked for me to make an unreadable "raw" partition a readable "NTFS" one, without loss of data. My scenario, in short, was that while the disk wasn't bootable, and Disk Management on another system would show it as "raw", chkdsk detected it as ntfs and repaired it:

  • disk (500GB Windows 8 boot drive from neighbor's Dell Optiplex system) showed up as "raw" in Windows 10 Disk Management
  • same disk - readable in MacOS 10.14 - i.e. could recover all files there
  • convert /fs:ntfs said, "disk is already NTFS" or something like that
  • chkdsk (w/o /F) said it was an NTFS partition and that there were a lot of file table errors

Copy of chkdsk output:

WARNING!  /F parameter not specified.
Running CHKDSK in read-only mode.
Read-only chkdsk found bad on-disk uppercase table - using system table.

Stage 1: Examining basic file system structure ...
  267088 file records processed.
File verification completed.
  1991 large file records processed.
  0 bad file records processed.

Stage 2: Examining file name linkage ...
  3541 reparse records processed.
  308192 index entries processed.
Index verification completed.
CHKDSK is scanning unindexed files for reconnect to their original directory.
  3541 reparse records processed.

Stage 3: Examining security descriptors ...
Security descriptor verification completed.
  20552 data files processed.
Errors detected in the uppercase file.
The master file table's (MFT) BITMAP attribute is incorrect.
The Volume Bitmap is incorrect.

Windows has checked the file system and found problems.
Run CHKDSK with the /F (fix) option to correct these.

Hope this helps someone else in the same situation.

3
  • 1
    chkdsk /F worked for me (fixing my 2nd partition on the HDD). Thanks Jun 27 '20 at 22:58
  • How do you run chkdsk /F if the partition does not even have a drive letter to pass as an argument for chkdsk? Disk management shows drive letter option greyed out. Feb 25 at 10:17
  • Re-reading my own comment - it doesn't make a lot of sense - looks like I was writing it in a hurry and still deep in the process - sorry about that. :) I think the key was that it was "raw" on the original system but detected as "NTFS" on a different one - and this is where I could run chkdsk /F successfully. Feb 26 at 17:02
-2

There isn't a way to change the partition from RAW to NTFS and keep all the data intact.

There is a method that you might be able to use to get to the data mentioned here . It's definitely worth a shot.

3
  • I think the disk is NTFS, but has been corrupted and is not recognized as NTFS anymore (read as RAW instead). He's asking if there's any way not to restore the NTFS file system, but just get it recognized as one.
    – Caleb Xu
    Jan 9 '14 at 21:16
  • 1
    Yes I think it has been corrupted, but never mind if i can't recognize it as NTFS. I just need to recover some data from it, then i'll re-install Windows 7. Jan 10 '14 at 11:25
  • 1
    Per test today on a disk with NTFS partitions showing as RAW, EaseUS referenced by this answer found three files on a partition that TestDisk 7.0's PhotoRec found 203 files on. Annoyingly, the trial edition EaseUS kept trying to contact the internet at program start, stop, and uninstall. Internet contact during uninstall prevented uninstall until one wised up and let network access attempts fail out. Wasted my time. YMMV.
    – kbulgrien
    Jun 27 '17 at 15:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.