2

I work in a domain setting where the domain is managed by Active Directory. The macs are set up with domain logins, no local profiles. I am trying to set the default dock for Mavericks. I used to copy the com.apple.dock.plist file into the template English.proj in the system templates file (basic instructions for Mountain Lion). Everything I have read about Mavericks docks settings suggest that I cannot set the dock for all users any more this way because of cached preferences?

All I see in preferences now is com.apple.dockfixtup.com? I tried copying that file over and it did not work. I usually follow these instructions https://apple.stackexchange.com/questions/100188/osx-10-8-how-to-keep-a-custom-dock-for-all-users-that-login

Anyone have any way of setting the dock preferences for all users that login?

Thank you for your time.

x-post from Stack Overflow

  • Have you tried restarting the dock process for all users yet? You'll have to run this from all users' accounts after the PLIST file has been moved or run it for them: killall Dock. Hopefully this will reset the cache and update any preferences. – Caleb Xu Jan 10 '14 at 0:18
1

It's likely the caching you're referring to that is causing the issue. You've got a few options that you can try, and the dock information should still be stored in com.apple.dock.plist

After you make the edits to your .plist try:

read /System/Library/LaunchAgents com.apple.dock.plist

If that doesn't do the trick you can kill the prefs daemon after making your edits:

killall -u yourusername cfprefsd
killall Dock
  • So after adjusting .plist and copying it over I tried logging in as a user that had previously not logged in to the computer. and the dock I had created was not the one displayed. – notantisocial Jan 11 '14 at 3:27
  • @notantisocial, there's a couple more things to note here: 1. if you could provide an example of your dock.plist that might be helpful; mavericks is fussy when you change this file 2. try using the read command above with the file you are copying over instead of the launchagent 3. try using killall cfprefsd before making the edits – l'L'l Jan 11 '14 at 4:48
  • I copied the .plist file from a user file where I had edited the dock, then went and found the file. I didn't actually manually edit it. I think copying that file into the template English.proj is what is not working. I can get you a copy. I am not understanding how running any commands under a particular profile is going to help? I want the dock to be default for every user that logs in. WHat am I missing? – notantisocial Jan 12 '14 at 19:16
1

You can't capture the dock preferences while you're logged in as the user to whom the dock belongs. This means you'll need to log in as another user, grab the dock plist from the user that has the desired dock, and then put it in the applicable user template.

To do this, you'll need to use the terminal to grab the file.

First, restart the computer, then log in to a second user that is not the one that you modified the dock under. Open up the terminal and use this command:

# sudo cp /Users/shortname/Library/Preferences/com.apple.dock.plist /System/Library/User Template/Non_localized/Library/Preferences

Replace "shortname" in that command with the shortname of the user with the desired dock.

1

Found a solution that may work. You will need 2 macs and a firewire or thunderbolt cable...

  1. set up your dock the way you want it to replicate.
  2. Connect the two macs with a firewire or thunderbolt cable.
  3. reboot the mac that has the correct dock into target disk mode. (hold down the "T" key while booting).
  4. on the second mac, access the original mac HD. Move the "com.apple.dock.plist" file manually to the "English.proj" folder.
  5. restart the original mac and disconnect from the second mac.
  6. When you join the computer to the domain, the admin account will have a standard mac dock. When you log out and log in as a domain user account, the corrected dock should appear. As the classroom admin, I don't care if the admin account has the modified dock as long as the general population appears correctly.

Apparently, if you try this on the single mac, the system has the .plist file busy and it doesn't copy correctly to the English.proj folder on OS10.9. Booting into Target disk mode takes the primary operating system out of the way and it copies correctly. Hope this helps...

  • Have you had success with this? – notantisocial Aug 15 '14 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.