89

I have a ssh connection to a machine which gets disconnected by that machine after 30 minutes of no user input. However, if I start something like top, the connection stays alive. Since this is a client's machine, I can not reconfigure that machine's SSH server. So I am looking for a way to automatically detect idleness and start something like top. Kind of a "screensaver" for Bash.

I know that I can do that with screen, but unfortunately screen is not installed, and I can not install software. So I need to use what Bash offers.

To make it clear: I am looking for a solution that I start once after logging in, and then I want to use that terminal, walk away, come back two hours later and continue working, without typing anything before walking away. Also, I am not looking to tunnel stuff (for that I recommend the great tool sshuttle)

Any ideas?

2
  • Just a quick note to make clear screen and Keepalive are not the same thing: for instance, if either ssh client or server gest disconnected, your ssh session will be terminated even if you have KeepAlive on, while a screen shell wouldn't be terminated. – MariusMatutiae Jan 10 '14 at 11:50
  • Possible duplicate of How to reliably keep an SSH tunnel open? – Murmel Jan 15 '18 at 22:30
116

To make it clear: I am looking for a solution that I start once after logging in, and then I want to use that terminal, walk away, come back two hours later and continue working, without typing anything before walking away.

The problem is that there is something (usually a firewall or load-balancer), which is dropping idle sessions. If you configure session keepalives, the keepalives will prevent network devices from considering the session as idle.

Linux / Unix / Cygwin OpenSSH fix:
The simplest fix is to enable ssh client keepalives; this example will send an ssh keepalive every 60 seconds:

ssh -o "ServerAliveInterval 60" <SERVER_ADDRESS>

If you want to enable this on all your sessions, put this in your /etc/ssh/ssh_config or ~/.ssh/config:

ServerAliveInterval 60

For more information, see the ssh_config manpage

Putty Fix:

Save this to your PuTTY "Default Settings"...

  • Click on Connection
  • Type 60 into "Seconds between keepalives"

putty_screenshot

41

In addition to Mike Pennigton's answer, I would like to make you aware of ServerAliveCountMax too.

  • The ServerAliveInterval will send a keepalive every x seconds (default is 0, which disables this feature if not set to something else).
  • This will be done ServerAliveCountMax times if no response is received. The default value of ServerAliveCountMax is 3 (see manpage ssh_config).

Example: If you set ServerAliveInterval to 60 and leave ServerAliveCountMax as it is, this means the keepalive will only wait for 3 * 60 = 180 seconds = 3 minutes before quiting.

To increase this to e.g. 2 hours of trying to keep the connection alive, you can do:

Per command:

Therefore you should consider to set

ssh -o "ServerAliveInterval 60" -o "ServerAliveCountMax 120" <SERVER_ADDRESS>

Persistent:

To make it persistent write it to /etc/ssh/ssh_config (will apply system-wide) or ~/.ssh/config (will apply user-only):

ServerAliveInterval 60
ServerAliveCountMax 120

Note

As dislick correctly pointed out, this might not what you want, depending on your situation:

  • If you would like to quickly terminate the session as soon as the server does not respond anymore, you should choose a low value for ServerAliveCountMax.
  • If you are more interested in keeping an already established connection (e.g. you go by train and have a high latency), you should choose a higher value for ServerAliveCountMax to allow ssh to keep trying to reestablish the connection.

See also:

2
  • 4
    I'm sorry, but this is wrong. ServerAliveCountMax specifies the amount of server alive messages which may be sent without receiving any messages back from the server. If you want ssh to exit after it freezes (so that you can restart it) you should actually set ServerAliveCountMax to a low number. See the manpage OP linked. – dislick Mar 22 '19 at 9:09
  • 1
    @dislick I had to think a little bit about this, but I think you are right depending on the context, hence I added a note to emphasize the context. – Murmel Sep 23 '19 at 11:57
10

I am using Mobaxterm and have also met with this problem. Mobaxterm also ships with an option to keep the client alive when the client is idle. Go to Settings -> Configuration -> SSH. There is section titled SSH settings, check the option SSH keepalive. Then it the problem should disappear.

enter image description here

2
  • does the "SSH keepalive" work in free edition... my session is getting disconnected even after checking up this option – samshers Aug 4 '19 at 11:02
  • Yes, it works. Your issue may have other causes. – jdhao Aug 5 '19 at 7:12
0

It is never too late...

But if you only using non GUI than something better than top might be crontab.

Just create a bash script that mkdir and rm that folder each 5 minutes

or

send /dev/null to /dev/null. lol.

12
  • How can this prevent ssh from disconnecting? – Kamil Maciorowski Feb 16 at 9:30
  • @Noajm Have you tried if it works? Why crontab? You do not easily know from a script/program executed in crontab if a ssh session is active, and where (which tty) to send the output? There are also downsides to writing and deleting something on the disk (if you don't have a partition to write to?). BTW If it works with top maybe it works just running date every 5 minutes, but from a script ... please edit your post if you want to modify something. – Hastur Feb 16 at 9:30
  • Try it. I use it for my collage server and works good for me. It does kick me out after 2-3 days – Noajm IsMy Name Feb 16 at 9:32
  • @Noajm Hi. Some servers, for example university clusters with user and group quotas and many logins, disconnect you from an ssh session after a set amount of time, if you have not performed disk I/O operations, regardless of the connection parameters requested by your client. Others delete your data from common areas if they haven't had recent access. In those cases you can think of I/O operations like touch to keep the session active. BTW If you have to keep an active session for 2 days I think you will find interesting screen. – Hastur Feb 16 at 9:50
  • A question: how did it work a script in crontab?? how did you find the session to keep alive? Can you say something more about it. Have a nice day. – Hastur Feb 16 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.