0

I posted this question before, but with no answer: (https://askubuntu.com/questions/400233/fstrim-is-taking-too-long). I'm using ubuntu 13.10, I call fstrim -v / on boot rc.local. Recently I realized that fstrim command is taking too long with above average CPU usage.

Is this normal ? It works eventually.

The only thing that changed, is this happened among Ubuntu failing to moung encrypted swap on startup. I fixed the swap problem, but fstrim still slow on startup.

Thanks.

2

I have experienced similar behavior on my Debian Jessie only once, but this article (http://blog.neutrino.es/2013/howto-properly-activate-trim-for-your-ssd-on-linux-fstrim-lvm-and-dmcrypt/) helped me to understand the trimming function and how to adjust my own system.

I'm also using LVM and LUKS, so as the article recommend, I have configured trimming options for both of this services, removed the parameter from fstab and scheduled job of fstrim.

You may consider to remove fstrim from /etc/rc.local, do configuration changes and schedule the job as suggested.

I have posted the same answer to your question on http://askubuntu.com in case somebody will find your question only there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.