1

I created a Debian Netinstall Bootable USB drive using a SanDisk Cruzer Edge. The USB stick booted fine but now I cannot reformat it back. Diskpart reads it as 0B used and 0B free, Disk Management doesn't detect any partitions, and Xubuntu and GParted (haven't tried Live) doesn't even detect it (no appearance on the desktop or fdisk). I am unable to format it with either diskpart's clear, SDFormatter, or Windows' Format tool (SDFormatter doesn't give the option and the format box doesn't appear). I used Win32DiskImager to create the bootable drive. How can I reformat it back to regular storage?

It turns out that my USB stick is on /dev/sdb1 according to ls -l /dev/disk/by-id. GParted seems to be working, but I don't know how to continue from here though. Hopefully I can sort it out myself.


Solved!

I used GParted to create a new partition table, then allocated it with Disk Management.

0

Does lsusb see your USB stick at all?

You can try smartmontools on the stick. It does work on some of them, the list of those it works on and those on which it does not work on is here. It appears your stick does not appear in either list (as a matter of fact, no SanDisk stick appears period), so all I can say is just try it.

You will need to install smartmontools,

   sudo apt-get install smartmontools 

then check whether the stick supports SMART,

   sudo smartctl -i /dev/sdb

assuming the stick is sdb. You may try enabling it,

   sudo smartctl -s on /dev/sdb

then testing the stick

   sudo smartctl -t long /dev/sdb

Hope this helps.

| improve this answer | |
  • lsusb detects it. Smartctl give info on sdb1, but not sdb (even though ls -l /dev/disk/by-id shows it on both) and is supported, and even shows it's actual size, 16GB (:D). The Extended Background Self Test has begun. What now? – Paul Clavier Jan 11 '14 at 18:18
  • @Paul Both good news. You wait for it to finish (don't hold your breath, it is going to be a few hours), when you have an output post it here again in its entirety. – MariusMatutiae Jan 11 '14 at 19:20
  • Thanks for the lsdisk command! Without you, I don't think I would of solved it! Ended up not needing the smartmontools – Paul Clavier Jan 11 '14 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.