0

In previous Fedora/CentOS distributions I was always able to run "gnome-session" over SSH with X11 forwarding. However, in Fedora 20, I instead get a window with a sad-face graphic that says "Oh no! Something has gone wrong. A problem has occurred and the system can't recover. Please log out and try again." In the SSH command window I get this:

[root@localhost ~]# gnome-session

** (gnome-session-check-accelerated:20362): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-ygVJHDDRF1: Connection refused
gnome-session-is-accelerated: No hardware 3D support.
gnome-session-check-accelerated: Helper exited with code 256

** (gnome-session-check-accelerated:20372): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-ygVJHDDRF1: Connection refused
gnome-session-is-accelerated: No hardware 3D support.
gnome-session-check-accelerated: Helper exited with code 256

** (process:20356): WARNING **: software acceleration check failed: Child process exited with code 1

I am able to run most applications over X11. I tried setenforce 0 and systemctl stop firewalld but the problem still occurs. The end of the "dmesg" output doesn't appear to be useful. Why would gnome-session fail to run on X11? Is this related to my other issue with firewall-config? Fedora 20 FirewallD GUI not working on X11 forwarding

0

You need to change your window manager to something that doesn't use 3D acceleration. Set your Gnome session to fallback mode and it should work fine.

  • Can you please elaborate; how do I make this setting? Is it a function of the server I'm connecting to or of my SSH client? I'm connecting from Cygwin using XTerm, with the "ssh -X" / "ssh -Y" commands. – user553702 Jan 12 '14 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.