I have a Dell Inspiron 15R 5520 laptop with Windows 8.1 64-bit installed. It works fine for a couple of hours, and suddenly the wifi start showing limited connection and I'm unable to access the internet while other devices, such as phones and tablets, are working fine at the same time.

Now when I disconnect and reconnect the laptop's wifi or I disable and re-enable the wifi, it starts working, or if I leave it alone for some time it reconnects by itself after 5-10 minutes.

I have:
• Dell Wireless 1704 802.11b/g/n
• Driver version:
• Driver date: 7/9/2012
• Wireless adapter: Broadcom

I'm not sure if there is any hardware issue. I have tried reinstalling the wifi driver, but I had no luck.

  • Which wifi adapter do you have? Intel Centrino® Advanced-N 2230? Dell Wireless 1704? Dell Wireless 1703? There are like 5 to 8 different ones it could be. Also are there any changes? Is this a new computer? Did you get a new router? – GeekyDewd Jan 12 '14 at 9:38
  • its Dell Wireless 1704 802.11b/g/n. no changes at all the laptop is more than one and a half year old. Initially I was using win7 don't remember if I had the same issue but with windows 8 and now with windows 8.1 I'm experiencing the same issue – zzlalani Jan 12 '14 at 9:52
  • Hey, I have that laptop. I do get that a lot in Windows 10. I use troubleshooter. Right click WiFi, the troubleshoot problems. Try restarting router. – juniorRubyist Sep 22 '15 at 8:01

I would verify you have the latest drivers as they may not have been updated since updating windows 8 to 8.1. Here is the official driver for your laptop and that wifi card: http://www.dell.com/support/drivers/us/en/19/DriverDetails/Product/inspiron-15r-5520?driverId=N0HCT&osCode=W764&fileId=3140004309&languageCode=en&categoryId=NI

  • This laptop is fairly old. That I think is best drivers – juniorRubyist Sep 22 '15 at 8:02

That problem may come from two issues:

  • You have upgraded your Win 7 to Win 8.1 without updating the drivers.
  • Your wireless card has an outdated/early Win 8.1 driver that creates that kind of bugs.

I would advice to use this driver for your card (it's the latest revision of the 1704 WLAN card from Jan 17) : https://downloads.dell.com/FOLDER03685478M/2/Network_Driver_YW21W_WN32_12.0.1.750_A04_01.EXE

This driver is older BUT designed for Win 8.1, you should try the newer one before this one : http://downloads.dell.com/FOLDER02688454M/1/Network_Driver_57TF3_WN_6.30.223.245_A01.EXE


I had exactly this same issue with a model 5540.Tried all the fixes offered here -drivers, router, access point. Nothing changed. Popped on a $10 USB network adapter and never looked back. Not worth spending hours of time and disrupting other users. Plus the USB adapter delivered faster speeds.

  • Just noticed this is an old thread. Still, might help someone later. – user76732 Jul 20 '18 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.