0

I have a CGN3 modem (Rogers) connected to a TP Link switch. This was working for many months but it has stopped working. Now, PCs get assigned 169.254.x.x when the switch is connected. Connecting directly to the modem is OK. Even those connected directly the modem-hybrid do not work any longer. The WiFi continues to work. Is this a DHCP issue?

  • I've tried factory resetting the modem -- no success
  • Tried different Ethernet cable, nothing
  • I've tried rebooting both devices with no success
  • I have NOT tried changing the switch yet

What should my next steps be? Is it possible for a switch to cause all ports to stop working, yet WiFi to continue to work?

For reference:

migrated from serverfault.com Jan 12 '14 at 18:19

This question came from our site for system and network administrators.

  • Downvoter, care to comment? – Vaughan Hilts Jan 12 '14 at 18:14
  • 1
    What if you give them static IPs? 169.254.xxx is an IP auto-assigned by windows when it can't find a a dhcp server – Hefewe1zen Jan 12 '14 at 18:24
  • @Hefewe1zen I tried assinging to the gateway (192.168.0.1 and giving a static IP -- nothing happens. Normally, I get "default gateway is not available". When assigning a static IP, windows is unable to do anything. It finds no problems, but connection is still unavailable. – Vaughan Hilts Jan 12 '14 at 18:32
  • 1
    If you try Wireshark to sniff for DHCP packets when you connect via Ethernet, do you see anything? If the switch is completely broken, you probably won't even receive any Ethernet frames. – yjwong Jan 12 '14 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.