-1

My ADSL modem lights are on. When I run diagnostics from my router's IP address it cannot ping the default gateway and DNS.

I contacted my ISP ,they say that there is no problem on their end.

What can I do next to resolve and troubleshoot the problem?

  • Did you check that the actual modem light showing the ADSL connection status is OK? Did you try to restart the modem (power off / power on)? – pabouk Jan 13 '14 at 14:07
  • Actually it seems to be a modem problem.It worked after I changed the modem. – ven93 Jan 14 '14 at 17:13
0

You can try to reset the router with a "hard reset". On most models of routers you have a reset button at the back, holding this in for a few seconds will wipe all the settings on the router.

From there on out you can enter your settings again and see if this works. if you can run diagnostics from your device to your router I take it that your NIC is fine. You can always test it as well by pinging the local address 127.0.0.1 and see the results.

In most cases a reset will sort out the issue. Just make sure you know how to set up the router before you reset it and that you have all the details you need to do so.

Hope this helps.

  • 1
    This might depend on your OS, but on at least Linux and windows you can not ping localhost to see if a NIC is fine. Both are hardcoded to recognise 127.0.0.1 and the ICMP never actually reaches the NIC. – Hennes Oct 24 '15 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.