I am using Internet Explorer 11 on Windows 8.1 and it has stopped working in the sense that it does not open anything except a white page and most of the settings are greyed out. Early this morning it started doing this for new tabs, I decided to restart my PC and now it is like this. I have tried disabling and then reeanbling in Windows features to no avail. Any ideas?

EDIT: Here is a screenshot enter image description here

  • Just out of curiosity, does it do this for all users? Have you tried another profile? – MDT Guy Jan 13 '14 at 18:33
  • Yes strangely enough it works fine on another user – Gerharddc Jan 13 '14 at 19:23
  • Does IE itself still works? Can you use IE as a normal web browser? Most settings are greyed out is very possible if this is a work PC connected to the Domain as the Domain Admin can set massive amount of locks on the IE to completely lock it down. – Darius Jan 14 '14 at 4:48
  • @Darius No, as stated in my question IE does not work, it refuses to load anything and just displays this empty white screen. – Gerharddc Jan 14 '14 at 6:10
  • 1
    Since @MDTGuy mentioned it (and you confirmed it) why not simply login as admin as other user, copy the content of the user folder out (or rename the folder), let the affected user log back in, which since the home folder is missing, recreate from scratch, and then copy the data back in? (without the Appdata folder preferably as whatever is causing it is most likely in the Appdata folder) – Darius Jan 14 '14 at 12:18

For me the same symptoms were caused by leaving Developer Tools console open when closing Internet Explorer (after fixing the problem I tried and succeeded in recreating the problem, by leaving it open again).

The fix for this situation:

  1. open Internet Explorer (No Add-ons)
  2. open Developer Console
  3. close Developer Console
  4. quit browser
  • Yes, this is the solution. Disable all adds-on not helping. – bingjie2680 Mar 20 '14 at 10:13
  • Don't know how you found that, but was exactly my issue... +1. – SimonC Jun 10 '14 at 20:57
  • 3
    Just hit this myself, if you don't have the "Internet Explorer (no Add-ons)" option, then running "iexplore.exe -extoff" from the cmd line will work. – AaronM Sep 11 '14 at 23:00

I have the same problem. I got IE to work only with the iexplore.exe -extoff command.

But I don't understand why it does not load anything. Chrome and Firefox both work, but not IE... I reset the options (using the mentionned command to enable the menu items first), I deleted all the cache and history... Nothing helps!

  • 1
    If only with Extensions Off it works, I would look at the extensions! In my network, I had an issue for the spam of about a week, and it was caused by the Flash player – Canadian Luke Feb 21 '14 at 17:23
  • So, what is the solution? Remove the Flash player? – serhio Feb 24 '14 at 9:58
  • apparently flash is built in to Windows 8, so I'm not sure if it can be disabled or not – Canadian Luke Feb 24 '14 at 15:01
  • I did a regedit /u for all the ocx and dll files in the windows Flash system folder. Now I have no problem.... – serhio Feb 25 '14 at 10:09

it worked perfectly to fix my white screen:

Before reset IE , kill IE process in task manger(End task IE process)

after click on reset you must see "Delete personal settings" box check the box

Try an Internet Explorer reset.

Click on Start » Run and type inetcpl.cpl to open Internet Options. Under the advanced tap is a reset button.

enter image description here

This may not be the issue, but it's worth a shot. I would also disable any and all firewall and/or AV software that may be installed.

  • Unfortunately I have already tried this to no avail. I'll try disabling anti-virus. – Gerharddc Jan 13 '14 at 17:53

Similar to what I posted above as a comment...

Try starting Internet Explorer without Add-ons. You can try this by clicking Start, searching "Internet Explorer", and choosing the option for No Add ons. If it loads OK, then it's an add on that's hanging.

I experienced this with MANY Windows 7 systems, and an outdated Flash player. I could only get by it by disabling Flash completely, or grabbing the latest version from Adobe's site, after uninstalling the old version of Flash.

  • IE works after starting it with the no add ons option but if I then manually disable all the add ons in the add on manager it still does not work. Also, it seems that Windows 8 and above have flash embedded in the OS and won't allow me to uninstall it... – Gerharddc Feb 23 '14 at 5:13

Try another user account on your computer, and see whether it is working there or not. If it is working then try to reset IE settings (Extensions, cache, ...).

Simply create another user account and see whether the problem exists there or not, in order to find it is a user-specific problem or machine-related.

If it is a user-related problem, there is a microsoft article "How to reset Internet Explorer settings". And there is a fixit utility there. Try it or you can also delete and recreate your account.

  • try to expand on your answer to with instructions on how to do what you're suggesting. – Outdated Computer Tech Feb 21 '14 at 18:49
  • The answer to this question is the key! – Mohsenme Feb 21 '14 at 19:05
  • It does indeed work on another account – Gerharddc Feb 22 '14 at 7:50
  • I updated my answer, check it back, please. – Mohsenme Feb 22 '14 at 9:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.