2

I moved recently and my TP-Link TL-WR841ND v7 with DD-WRT v24-sp2 (11/21/10) std (SVN revision 15778) started to work oddly.

Previously:

The router was connected to another (ISP's) router/modem. The Internet connection ran at 50 Mbps and worked as expected. (40+ Mbps via WiFi, 49+ Mbps via Ethernet.)

Now:

The TP-Link router is connected to a different router/modem (newer model) with the same ISP. The Internet connection 120 Mbps. With a direct connection to the ISP's router via RJ-45 cable, the Internet speed is around 85/10 Mbps with a ping of 8 ms.

However when I connect through the TP-Link, the speed falls dramatically - it never exceeds 10 Mbps and the ping is unchanged. There is no difference if I use RJ-45 (cat6) or WiFi (NG-Mixed, WPA2).

I've tried:

  • Changing WiFi broadcast channel.
  • Using different Ethernet ports in the TP-Link and other RJ-45 cables between the TP-Link and the PC.
  • Setting TP-Link to connect using DHCP.
  • Cloning the PC's Ethernet MAC address.
  • Restoring factory defaults.

I've had no luck. Any ideas?

2

Did you check if the TP-Link got a full duplex or a half duplex connection on the WAN-port with the modem.

Some providers force full-duplex with their modem and if your TP-Link is at auto negotiate this will fail miserably. Try setting the WAN-port TP-Link to full-duplex.

If the modem is at full duplex and your router at auto negotiate.
you'll get a duplex mismatch with all the troubles with it.

You can set the DD-WRT to full duplex like in the picture below:

enter image description here

  • Unfortunately I have no VLANs tab under Setup - is there any other way to force full-duplex on TP-Link? I've updated to DD-WRT v24-sp2 (03/25/13) std - build 21061 - latest compatible with WR841... – Piotr Nawrot Jan 13 '14 at 23:29
  • 1
    Is your connection indeed half duplex? Can you see the duplex state in the status page? I will need to look tomorrow why that page doesn't show for you (don't have access to my DD-WRT at the moment). (And if it is i take it you can't change the duplex setting on the modem to auto.neg.?) – Rik Jan 13 '14 at 23:37
  • I can't change modem's settings. But diagnosis seems right - log after physically reconnecting cables: Jan 14 01:12:39 DD-WRT kern.info kernel: [ 103.680000] eth1: link down Jan 14 01:12:57 DD-WRT kern.info kernel: [ 121.680000] eth1: link up (1000Mbps/Full duplex) Jan 14 01:13:41 DD-WRT kern.info kernel: [ 165.670000] eth0: link down Jan 14 01:14:01 DD-WRT kern.info kernel: [ 185.670000] eth0: link up (10Mbps/Full duplex) Question remains - how to force eth0 to go 100Mbps? – Piotr Nawrot Jan 14 '14 at 0:19
  • Hey, I don't see the VLANs in my old Linksys either. But the WAN-port should be assigned to eth1, not eth0. See here. What is it in yours? If it is eth1 your logs suggest ` eth1: link up (1000Mbps/Full duplex)` which means it is at full duplex (and 1000Mbps needed for the 120Mbps). Not sure about the inner workings of DD-WRT and if eth0 is used for something. – Rik Jan 14 '14 at 9:19
  • 1
    BTW. do you have a 1Gbps network card in your computer (and tested it)? (or could you test with a computer with such a network card?) Just wondering if you can get the 120Mbps your provider is offering with the proper network card. If you do get 120Mbps then it probably is best to invest in a router which can handle it (on the WAN- and LAN-side). (Yours only goes to 100Mbps max. with all the problem it faces if your modem forces a 1000Mbps-FD connection) – Rik Jan 20 '14 at 15:36

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.