0

I don't understand this AIX.

How do I do sudo apt-get on AIX?

-bash-3.00$ sudo
-bash: sudo: command not found
-bash-3.00$ apt-get
-bash: apt-get: command not found
  • 1
    You do not. You use the OS or distribution specific package manager. There seems to be none for AIX. As for sudo, does it even exist on AIX or they they usually su for these things? If there a sudo on the system (not just in your path, e.g. look for it with find). – Hennes Jan 14 '14 at 11:34
7

Oh man, you are definitely going to have a very bad time.

You come from Ubuntu. Here you don't have sudo, but you may have su. Check it and if you do have it, this problem is solved.

AIX not having Advanced Packaging Tool framework support is not easily solvable. Take into account that if you ran fedora or CentOS you would not also have those, and you would have to front the software installation using selection by yum, lower level rpm packaging handlers, or software build. Using AIX you most probably will have to face manual software builds.

  • heh, might be worth bribing someone familiar with the system with lunch for advice. AIX isn't all that common – Journeyman Geek Jan 14 '14 at 11:35
  • i've a super machine that i cannot do anything with... – alvas Jan 14 '14 at 11:38
  • imagine this: '-bash-3.00$ python Python 2.1.1 (#5, Nov 16 2001, 07:48:19) [C] on aix4 Type "copyright", "credits" or "license" for more information. >>> '. WHO THE HECK doesn't update for 13 years?! – alvas Jan 14 '14 at 11:39
  • Hey @alvas do you have the #$%&ing su or not? – uprego Jan 14 '14 at 11:46
  • 2
    Guy wipe that operating system out and prepare to get hands on with Debian (or to get fired). – uprego Jan 14 '14 at 11:54
7

apt is a Debian only application that was inherited by ubuntu. Having it work on AIX would be akin to trying to run yum on Ubuntu. There is no reason whatsoever this command would work

Unfortunately, it looks like AIX systems don't have a repository for its package manager at all - you will need to obtain AIX packages (which seem to be RPMs) or compile things yourself. As per the comment by wally, AIX has installp and the smitty install command. They do seem to use rpms, but rpms for linux distros are unlikely to work.

  • AIX comes with RPM and installp (publib.boulder.ibm.com/infocenter/pseries/v5r3/index.jsp?topic=/…). For the most part you use "smitty install" to install software. Sudo is available for AIX (sudo.ws/sudo/download.html). -- Edit: Oh, and you can download a lot of packages from IBM after a very quick google search for "AIX sudo" or whatever. – Wally Apr 1 '14 at 16:00
  • Thanks. I've updated my answer as per your comment. With a bit more fleshing out, your comment might have been a great answer on its own (and its not really too late to do that). – Journeyman Geek Apr 4 '14 at 1:27
3

Aix uses it own software software system through the System Management Tool (a.k.a. SMiT).
There is limited support for RPM's but these have to be build for Aix.
Normal Linux RPM's won't work at all.

sudo is available (but not default) on AIX 5 and later (could be AIX 6, I'm not sure). But it needs to be setup by the system administrator. Normally it isn't used and you need "su" to elevate yourself to system admin.

AIX is not LINUX. It is a completely different OS and many things you take for granted on a Linux system are just not there or done by other software.

By the way: From that Python line in the comments I see you are on Aix version 4. That has been obsolete for years. Current version is 7, with extended support for 5.3 and 6 still available.

  • Give me a redhat, i can yum my way out. With this, it's basically career suicide as a sys admin... – alvas Jan 14 '14 at 12:09
0

This guy has solved the yum / apt-get rpm package management issue on AIX, kind of:

http://earth2baz.net/2014/03/19/rpmrepos/

You have to build your own local repository though. Maybe someone can grab his code ( rpmplus ) and get it to work with curl or wget or something similar. For now, it's the best thing we've got. Hopefully IBM will get their act together and make this functionality available in SUMA or make it a SMIT panel ( smitty rpminstall, please ).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.