-2

A few hours ago I was doing a research work when I finally decided to save the data in Notepad and call it a day, it isn't responding. When I press File > Save, the "Save As" dialog window appeared and it just froze there.

Same thing happened when I open another instance of Notepad, works, but also froze up when "Save As" dialog window appears.

By the way, my CPU Usage stays at 35% - 45% (after playing a game), I wonder if there's anything to do with the Notepad freezing?

My disk activity indicator isn't flashing; doesn't flash when I tried to click on it.

8
  • How large is your file? Jan 14, 2014 at 14:33
  • Does this happen ANY TIME a save dialog opens, or just when it opens from notepad? (for example, open paint and try to save a picture...) Jan 14, 2014 at 14:42
  • 4
    Do you have any mapped network drives? Any external drives that may be plugged and not responding? Jan 14, 2014 at 14:45
  • 1
    If you have a consistently high CPU usage after playing a game, find out why (using Process Explorer or similar tools). If your Notepad hangs when you try to save, find out why (using Process Monitor). Jan 14, 2014 at 14:46
  • 2
    I would disable wifi and remove your ethernet cord (if attached) to ensure there are no interferences with your network. I've experienced similar issues where applications crash when preparing to save to a drive on our network.
    – root
    Jan 14, 2014 at 15:11

4 Answers 4

0

Untitled - Notepad (Not Responding)

On Windows10 2021 with latest updates, and i still get "Notepad -(Not Responding) sometimes when saving.

The window is then grayed out, in Task Manager the specific Notepad also shows up as "Not responding". Hovering the mouse over the grayed out window, shows rotating pointer as if the Notepad is busy doing something, tried waiting for hours but no luck with it fixing it self.

Windows10 thus basically looses all the work in the notepad, can't even select it to copy to a new notepad.

Not sure how to debug this further.

0

Turn on Network Discovery and File Sharing. Fixed it for me.

-1

Have you tried restarting your computer and doing this as soon as your computer starts? You could also try restarting in safemode by pressing F8 when the windows screen comes up during startup and then try your notepad.
if either of these work, then you can figure out if you have a software or resource problem. I would also run MalwareBytes to make sure you don't have any viruses using up your resources and blocking programs.

You could also try copying it into word, or google docs to preserve it

-2
  1. How big is the text file is it, As big file tend to take a bit amount of time to save.
  2. Are you saving the file on some network drive or a file server if so please check the network drive is responding properly.
  3. Check if you are trying to save some malicious code in the text file as the antivirus could be detecting it as a threat.
  4. None of the above then it could be a problem with your Operating System do a SFC/SCANNOW in the command prompt
  5. Check if you don't have a problem with your hard drive.

Please let us know if this doesn't work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .