24

When adjusting the volume in Windows 8.1, a box appears at the top left corner of the screen. This box sticks around for ~13 seconds before it fades away. If you attempt to dismiss it by click on it, it switches to the music app.

How do you disable or dismiss this annoying box? At the very least, can the time visible be adjusted? More times than not, it's in the way.

screenshot of box in top left corner of screen

  • 1
    Not a true solution because it's just running from the problem, but I think adjusting the volume from the desktop's notification area icon (the speaker) shouldn't trigger the box. – Ariane Jan 14 '14 at 16:18
  • 1
    I can confirm what James is saying. My desktop is a custom build, so every part inside the case I picked up and installed myself, no bloatware, everything installed is what I chose to be on the system. I went with Windows 8 (now upgraded to 8.1) for the better SSD support, and this volume overlay shows up for me as well. This is not a third party app, this is a feature included with Windows 8/8.1. – MattD Jan 17 '14 at 15:47
  • Unfortunately, all the research I've done indicates that there's no way to control if this overlay shows up, or how long it's displayed; no registry hack, no UI setting, nothing. Only thing I can confirm from my Windows 8.1 box is that the overlay doesn't take ~13 seconds to go away, more like 3 seconds. I have a volume roller on my keyboard, and it shows up any time I use it. I can only conclude it's staying up so long due to whatever app you're using that's displayed along with it (which I have yet to see my system do). – MattD Jan 17 '14 at 17:25
  • this probably comes because you are using the Windows 8 Music App. Download VLC or some other Music Player and set it as default. – Devid Jan 20 '14 at 0:19
12
+50

Windows 8.1

Open the Settings Charm, click on "Change PC Settings", then Ease of Access > Other Settings, and change the length of time to show notifications for in the drop-down box.

Windows 10

Open settings and click on "Ease of access", then scroll down to the drop-down menu called "Show notifications for" and select a time.

(Picture below supplied by Semnodime)

Windows 10->Settings->Ease of access->notifications time

| improve this answer | |
  • Welcome to SuperUser! I tried your solution and it worked perfectly. My notification time was set to 15 seconds (this must be the default). It is now set to 5 seconds and the box disappears very quickly. Thank you! – James Hill Jan 21 '14 at 2:34
  • 1
    @EdwardBlack Literally the same, except it's "Other options" instead of "Other Settings" – binaryfunt Nov 12 '16 at 23:20
  • 2
    I have german UI so I can't find it... :( a few screenshots would be helpful – Black Nov 14 '16 at 8:39
  • 3
    The minimum available value is 5 seconds, what if this period is still long, is there any Registry value to customize this setting – Amer Sawan Jan 4 '17 at 12:30
  • 1
    @AmerSawan I suggest you open a new question asking if it can be reduced to less than 5 seconds – binaryfunt Jan 4 '17 at 12:50
10

I have no idea why the moderator random deleted the working solution. There is a small tool called HideVolumeOSD which can hide the overlay:

To hide the volume OSD you can select the menu item “Hide Volume OSD” or just click on the tray Icon.

enter image description here

With this item you can toggle between visible and hidden volume OSD. If you exit the application, the volume OSD is always restored to visible state.

You can download it here and the sourcecode can be found on github

| improve this answer | |
-1

Just adjust the volume from the Charms bar or the taskbar. In either of these cases the volume control will not show.

The volume control only shows by default for about 3 seconds. If you interact with it (i.e. move your mouse over it, click it, etc.) or keep adjusting the volume, it will stay up longer.

This feature was added to Windows 8 in attempt to copy the Mac volume display - which shows up in the middle of the screen.

And, by the way, it will only switch to the Music app if you are using the Music app. Just use Windows Media Player if you want to avoid this.

| improve this answer | |
-1

No above mentioned suggestion solved this issues, I got new idea for get rid off this mess. just open "regedit" and follow the step mentioned below.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ImmersiveShell\EdgeUI

DisableTLcorner DWORD

  • 0 = Enable TL corner
  • 1 = Disable TL corner

Now restart your PC.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.