I have a "main" router that connects to the internet, and then a wireless router that connects to that. The main router's DHCP is disabled, and a computer hooked to that has a DHCP server running serving up 10.0... addresses with mask The wireless router does not allow that subnet, but only 255.255.255.x choices.

I have four wireless client devices that connected to the wireless router. Two are somehow able to get 10.0... addresses from the DHCP server computer, in addition to the 192.168... addresses they get from the wireless router's built-in DHCP server. I can ping the 10.0... addresses from the DHCP server computer successfully.

However, the other two clients are somehow not able to get 10.0.... addresses from the DHCP server computer, but only the 192.168.... addresses from the wireless router's built-in DHCP. They can access the internet but not anything on the 10.0 network.

Why is there a difference among the clients, and how can I get the latter two clients to get 10.0.... addresses so I can reach them from the main network like I can with the other two?

  • 1
    Are you able to print out an ipconfig/ifconfig? I'm interested to knowing how your wired computer can get two different IP address, unless they have both nic and wireless card in them. – shinjijai Jan 14 '14 at 18:24
  • @shinjijai, that's a good question, and now that I look at it, they must not have been wired, even though it said 'LAN' instead of 'Wireless' in the router's DHCP clients table. Reason: one's an iPad, the other an Android device... So: I'm not sure how to get the info you requested but thanks nonetheless because I should now update the question... – Kev Jan 14 '14 at 19:25

In order to solve your problem, you have to:

1) disable DHCP on the wireless router.

2) connect the main router to the wireless router with a cable from a LAN port to another LAN port, not to the WAN port of the wireless router.

  • I'll try this, but will it work given the subnet restriction on the wireless router? And will I have to change the wireless router's local IP to match its WAN IP even though it won't really use the WAN IP? Or does it somehow not use any IP to forward packets within its LAN? – Kev Jan 14 '14 at 19:15
  • 1
    @Kev If you turn DHCP off, the subnet rrstriction becomes irrelevant. As for the WAN IP, it again becomes irrelevant, since you have no cable on the WAN port, thus that inteface is not used. In fact, you are right, it does not use IP addresses to forward packets: it will act as a switch, using only MAC addresses. – MariusMatutiae Jan 14 '14 at 19:21
  • The subnet restriction is for its local IP, though. But that's helpful to know about switch/MAC-addr etc. – Kev Jan 14 '14 at 19:38

The wireless router does not allow that subnet, but only 255.255.255.x choices.

Your wireless router is stupid. :) Flash it to DD-WRT to make it less stupid if you can, or purchase a better one.

Do you really need/want wired and wireless nodes on different subnets? If not, the optimum situation is to only have 1 DHCP server running, routing disabled on the wireless (it acting as a bridge only), and have everything, whether wired or not, on the same subnet. If the only reason you are using two subnets is because you cannot change the configuration of the wireless, ditch it and get a new one that lets you configure it more sanely.

DHCP relies on broadcast packets to function. Broadcast packets do not cross routers without a helper program forwarding them. The helper program would have to run on your router. It sounds like your router is not customizable enough to even consider this, but do check to see if any "DHCP forwarding" etc. is possible. You'll then want to disable the DHCP on the wireless router.

If you really need to keep this router, and you really want your 10.x.x.x machines to be able to initiate connections into the 192.168.?.x machines, then you need to set up NAT on the wireless router and open ports.

Note that on the 10.x.x.x machines, you'll need to use the router's IP to reach into wireless clients behind the wireless router, not the actual IP the wireless router gives them.

  • It's a Cisco E900, and more COTS routers seem to be doing the dumb-down route. As I said though, the wireless router seems to forward DHCP packets for wired clients, so it is capable of that. But anyway, it has a feature called RIP, will that cause it to act as a bridge? (Currently it's instead NAT-enabled, but with no manual routing set up.) As for reaching clients behind the wireless router, why is that true for wireless clients but not wired ones attached to the same router? – Kev Jan 14 '14 at 19:06
  • If you have a LAN port of your first router connected to a LAN port of your second wireless router, then broadcast traffic, e.g. DHCP, can reach any port on either set of LAN ports. – LawrenceC Jan 14 '14 at 19:22
  • Will other traffic also get through though once the second wireless router's other devices get a 10.0 address? E.g. will I still be able to remote administer it from the first router's LAN? – Kev Jan 14 '14 at 19:28
  • @Kev both routers will have seperate IP address on the same subnet, so you'll can administrate either router by going to their respective IP address. – shinjijai Jan 14 '14 at 19:34

You're doing double NAT. Don't do double NAT.

Disable NAT on the wireless router so it's just an Access Point (AP); that is, just a device that takes traffic from the wireless clients and bridges it to the Ethernet. Also disable its DHCP server, and set it to get its own IP address from DHCP (that is, from the separate DHCP server box you have on the wired LAN).

Many home routers let you disable NAT, and the WAN port automatically becomes an extra LAN port. Other routers either don't let you disable NAT, or don't let you use the WAN port as a LAN port when NAT is off. So you may have to plug the wireless router's LAN port into the LAN port of the upstream router.

One last tip: I'm pretty sure your LAN would break down before you get 16.8 million hosts connected to it, so you really don't need to be running a /8 ( subnet mask on it. You can probably get away with a /24 (

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.