3

I followed the suggestion to disable compressed memory, now I want to get it back.

I checked the code, it was 4 before disabling.

So, I tried:

sudo nvram boot-args="vm_compressor=4"

That was not effective.

Please, how to get the feature back?

5

You're confusing the boot argument vm_compressor with the sysctl variable vm.compressor_mode; they don't correspond in values. As I understand it, this is the mapping:

nvram boot-args=""  =>                 sysctl vm.compressor_mode=4  =>  memory compression enabled (normal)
nvram boot-args="vm_compressor=1"  =>  sysctl vm.compressor_mode=1  =>  memory compression disabled

To restore the default behavior, either:

  • remove the one boot argument from NVRAM; or
  • remove all boot arguments, sudo nvram -d boot-args

– then restart the Mac.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.