2

I've got an interesting problem; I've got a TV and 3 monitors. I would like to mirror my middle monitor to my TV via an HDMI switcher, because Steam Big Picture just doesn't work well with multi-monitor setups (shuffles monitor order and I can't plug in 4 concurrent monitors with my graphics card).

I have HDMI splitters which I use to output my game consoles to my TV, my monitor and my capture card, no problems. My video card/monitor both support HDMI and plugging HDMI in direct to the monitor is no problem. But once I introduce the splitter and plug the TV and monitor into it, things get weird. Suddenly the monitor won't work unless the TV is turned on (not acceptable; the TV is usually off during normal PC use).

The monitor also suddenly underscans (black borders at all sides) when the TV is plugged in, and turning on Overscan on my monitor doesn't entirely fix it. If it matters the TV is actually set to "Justscan" AKA no overscan, so I'm not sure why splitting suddenly introduces underscan. It seems like the problem is the PC is acting like it's connected to the TV first and foremost, so if the TV is off, there's no display. However switching which slot which HDMI cable is plugged into doesn't change the situation; the PC seems to always act as if the TV is the "monitor" and only mirror to the monitor if the TV is on.

Is there a way to split this signal to my TV and monitor seamlessly? Willing to purchase new hardware, but I already have HDMI splitters and an HDMI switch and my setup works perfectly for 4 game consoles.

If it matters I'm using Windows 7 64 bit, an ASUS monitor with HDMI, DVI and VGA inputs, a Raedon 6950 which supports 3 monitors and has an HDMI out. Other monitors are on DVI, one via a Displayport to allow 3 monitors. HDCP shouldn't be the problem since these same splitters work with PS3 (which uses HDCP).

  • Does the monitor work through the splitter if it's the only device connected? – Tim Stone Jan 26 '14 at 18:49
0

Hmmm...honestly not quite sure what went wrong earlier but I have it working now, so I'll go through my steps one by one.

First, simply connect the target monitor direct via HDMI to the graphics card to make sure it works. You might need to fuss with the "screen resolution" options in Windows or your graphics cards' settings to make sure the HDMI monitor is being used and is the primary display (primary display is important to make sure full screen games are mirrored, they will always appear on the primary display).

Once you're sure the HDMI connection is working, introduce the splitter and connect only the graphics card to the splitter In and the monitor to the splitter Out. Confirm everything is working the same. Next, add an HDMI cable for the TV to the splitter Out and into the TV. Confirm all is working.

At this point you'll want to note that every time the HDMI input on the TV changes, your monitors may flicker. This seems to just be a problem with HDMI and/or how graphics cards (or just mine?) handle HDMI. It shouldn't be anything to worry about, as your PC's displays should return to normal after the flicker, it's just annoying. It seems to only happen when my HDMI switch flicks back to my PC's HDMI out, even if the TV isn't on.

For what it's worth, I have a fairly exotic setup so the HDMI is going from graphics card to a splitter to the monitor and a switch and from the switch to a splitter that runs to a capture card, TV and second monitor. Even then, the setup works fine.

If at any point the monitor's image is underscanned (black bars at all edges), make sure to disable underscan in AMD Vision/Catalyst control center in My Digital Flat-Panels > Scaling Options. It should probably read "0", all the way to the right. Make sure the TV/monitor is set to "Just scan", "1:1 pixel ratio" or whatever your vendor calls "no overscan". Not sure if this step is needed on Nvidia cards, but it if is the setup is probably similar.

Computer monitors are meant to show the whole images and most TVs are not, so the underscanning was an attempt by the graphics card to keep everything on screen. However, ideally you should set both graphics card and TV/monitor to 1:1 scaling, since scaling is awful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.