I recently installed MAMP on our server in order to launch a Wordpress site. Though everything is working fine I am not the computer's main user, something which results in long downtime when it has to be rebooted for maintenance.

I was looking for a way to automatically load MAMP on start-up, regardless of who logs in. This lead me to run a script for loading the Apache and MySQL servers on start-up, using the files startApache.sh and startMysql.sh located in Applications/MAMP/bin. I found that the Apache server could be loaded from any admin user with no problem. The MySQL server however will only start when I log-in with my own account (the one under which the installation took place).

Being able to run these scripts without being prompted for a password would be a plus, but it is more important that any admin can start the MySQL server.

I'd appreciate any help you can give me.


It's almost certainly a permissions problem on the files in MAMP/bin.

If you do ls -l in /Applications/MAMP/bin you will probably find that the MySQL start script or executable is set to '-rwx------' or similar so that only the owner can run them. Change the permissions via chmod a+x filename and it should fix it.

(I apologise for my less than precise answer but I removed MAMP a few months ago and now use VMs in Fusion for the same thing.)

As an alternative set the preferences for the MAMP application to Start Servers when starting MAMP and then run the application at user login.

|improve this answer|||||
  • Permissions for the startMysql.sh file are -rwxrwxr-x@ com.apple.TextEncoding. It was a good guess, and I thank you, but I fear that was not the problem. – cortu01 Jan 17 '14 at 13:04
  • Could the problem rest in the MySQL database users' accounts? – cortu01 Jan 17 '14 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.