I solved this a while back by uninstalling and reinstalling Chrome but it didn't work the first attempt at this because I prematurely believed it failed

I right-click on Google Chrome pinned to my taskbar and see this:

Broken TASKS

And then I select either New window or New incognito window and see this:

enter image description here

Is there a way to fix these links?

If so, how?

If not, would uninstalling and reinstalling Chrome work or put me back at the same problem?

Please Explain Like I'm Five

Backstory (Possibly Negligible to Answering Question)

A few hours ago, opening a new page with an already open Chrome would not load or even give an error page. It remained blank. Internet connection was good so I disconnected & reconnected with no change. So I closed Chrome, clicked the pinned Shortcut on Taskbar to reopen, and nothing would happen. I opened Firefox & downloaded a new Chrome (without deleting old) hoping to "refresh" things and believe the shortcuts would work out then. Not so lucky. But opening the file location of the desktop shortcut, I clicked on "new_chrome" which transformed into "old_chrome" (it just did) which opened successfully.

The key shortcut Ctrl+N and Ctrl+Shift+N both worked but the taskbar shortcut still failed me. (In retrospect, I might've had better luck removing it & replacing it with the "old_chrome" application in that file location.)

So thinking to put everything right again, I'd just uninstall Chrome. Did so (which removed both). But reinstalling gave an error that led to me doing a chkdsk to fix a corruption. With Google Chrome uninstalled & everything booting up normal, I reinstalled it. I can now click on the taskbar icon, the desktop icon, but these Tasks are broken. So now I'm here.

  • Try the following: 1. Right click Google icon in taskbar. 2. Right click on Google Chrome. 3. Click on Properties. 4. On the Shortcut tab, ensure target is "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" and Start In is "C:\Program Files (x86)\Google\Chrome\Application" (with quotes on both). – LDC3 Aug 25 '14 at 2:30

I had the same issue and fixed it as follows:

  1. Right-click on the Start button and select Properties
  2. On the Start Menu tab check the Store and display recently opened items in the Start Menu and the taskbar checkbox
    enter image description here
  3. Click OK to save and close the window
  4. Open the Run window (shortcut: Win+R) and run the following command:

    C:\Program Files (x86)\Google\Chrome\Application\chrome.exe --enable-custom-jumplist

Mine worked after this. You can also go back and un-check the privacy box you checked on step 2 and it should still work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.