1

Connections are refused on my server. Note: I am trying to connect from localhost here.

Command I'm trying to use to test:

user@hostname:~$ telnet localhost pop3
Trying ::1...
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused

Same error when I try with imap.

The dovecot wiki suggests trouble shooting for the issue, however I have already tried the fixes. I have the protocols added in the config, and I have the listen option set to *. My config is below. I am not sure what is wrong? ## Dovecot configuration file

# If you're in a hurry, see http://wiki2.dovecot.org/QuickConfiguration

# "doveconf -n" command gives a clean output of the changed settings. Use it
# instead of copy&pasting files when posting to the Dovecot mailing list.

# '#' character and everything after it is treated as comments. Extra spaces
# and tabs are ignored. If you want to use either of these explicitly, put the
# value inside quotes, eg.: key = "# char and trailing whitespace  "

# Default values are shown for each setting, it's not required to uncomment
# those. These are exceptions to this though: No sections (e.g. namespace {})
# or plugin settings are added by default, they're listed only as examples.
# Paths are also just examples with the real defaults being based on configure
# options. The paths listed here are for configure --prefix=/usr
# --sysconfdir=/etc --localstatedir=/var

# Enable installed protocols
!include_try /usr/share/dovecot/protocols.d/*.protocol
protocols = pop3 pop3s imap imaps
pop3_uidl_format = %08Xu%08Xv

# A comma separated list of IPs or hosts where to listen in for connections.
# "*" listens in all IPv4 interfaces, "::" listens in all IPv6 interfaces.
# If you want to specify non-default ports or anything more complex,
# edit conf.d/master.conf.
#listen = *, ::

# Base directory where to store runtime data.
#base_dir = /var/run/dovecot/

# Name of this instance. Used to prefix all Dovecot processes in ps output.
#instance_name = dovecot

# Greeting message for clients.
#login_greeting = Dovecot ready.

# Space separated list of trusted network ranges. Connections from these
# IPs are allowed to override their IP addresses and ports (for logging and
# for authentication checks). disable_plaintext_auth is also ignored for
# these networks. Typically you'd specify your IMAP proxy servers here.
#login_trusted_networks =

# Sepace separated list of login access check sockets (e.g. tcpwrap)
#login_access_sockets =

# Show more verbose process titles (in ps). Currently shows user name and
# IP address. Useful for seeing who are actually using the IMAP processes
# (eg. shared mailboxes or if same uid is used for multiple accounts).
#verbose_proctitle = no

# Should all processes be killed when Dovecot master process shuts down.
# Setting this to "no" means that Dovecot can be upgraded without
# forcing existing client connections to close (although that could also be
# a problem if the upgrade is e.g. because of a security fix).
#shutdown_clients = yes

# If non-zero, run mail commands via this many connections to doveadm server,
# instead of running them directly in the same process.
#doveadm_worker_count = 0
# UNIX socket or host:port used for connecting to doveadm server
#doveadm_socket_path = doveadm-server

# Space separated list of environment variables that are preserved on Dovecot
# startup and passed down to all of its child processes. You can also give
# key=value pairs to always set specific settings.
#import_environment = TZ

##
## Dictionary server settings
##

# Dictionary can be used to store key=value lists. This is used by several
# plugins. The dictionary can be accessed either directly or though a
# dictionary server. The following dict block maps dictionary names to URIs
# when the server is used. These can then be referenced using URIs in format
# "proxy::<name>".
4
  • Have you tried using the port numbers instead of the service name when testing via telnet? – ernie Jan 15 '14 at 20:38
  • @ernie I tried using the port 110 and same problem. – ComputerLocus Jan 15 '14 at 20:51
  • All right, and to ask the obvious, you started the daemon and verified it was running? – ernie Jan 15 '14 at 20:52
  • @ernie Yep ps -A | grep dovecot reports that it is running – ComputerLocus Jan 15 '14 at 20:54
1

You haven't define appropriate listeners for protocols. Try to begin from the single-file config like that:

## Dovecot configuration file

mail_location           = maildir:/var/mail/%d/%n
protocols               = imap pop3
listen                  = *

mail_uid                = mailnull
mail_gid                = mail
first_valid_uid         = 26
first_valid_gid         = 6
last_valid_uid          = 0
last_valid_gid          = 0

log_path                = syslog
syslog_facility         = mail
auth_mechanisms         = plain
auth_socket_path        = /var/run/dovecot/auth-userdb

mail_plugin_dir         = /usr/local/lib/dovecot
postmaster_address      = postmaster@%d
hostname                = %d
sendmail_path           = /usr/local/sbin/exim
lda_mailbox_autocreate  = yes
lda_mailbox_autosubscribe = yes

passdb {
  driver        = sql
  args          = /usr/local/etc/dovecot/dovecot.sql
}

userdb {
  driver        = sql
  args          = /usr/local/etc/dovecot/dovecot.sql
}

protocol lda {
}

protocol pop3 {
  pop3_client_workarounds = outlook-no-nuls oe-ns-eoh
}

protocol imap {
  mail_plugins          = quota imap_quota antispam
  imap_client_workarounds = delay-newmail tb-extra-mailbox-sep tb-lsub-flags
}
## - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
service auth {
  unix_listener auth-userdb {
    mode        = 0600
    user        = $mail_uid
    group       = $mail_gid
  }
}

service imap-login {
  inet_listener imap {
    port        = 143
  }
  inet_listener imaps {
    port        = 993
    ssl         = yes
  }
}

service pop3-login {
  inet_listener pop3 {
    port        = 110
  }
  inet_listener pop3s {
    port        = 995
    ssl         = yes
  }
}
####

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.