This is a follow up to the question, Ping to dnsmasq's host resolvesto, because that answer doesn't work for me. It should work -- I found another one having the same answer: https://bugzilla.redhat.com/show_bug.cgi?id=470391

In both above cases, the cause was having dnsmasq's hostname listed as in the /etc/hosts file. But mines doesn't:

$ head -2 /etc/hosts       localhost.localdomain           localhost   jupiter.myhost.dyndns.org       jupiter

but dnsmasq's hostname is still resolved as

$ nslookup jupiter 

Name:   jupiter

What's wrong?


I'm using dnsmasq as my DNS server, and I didn't put any configuration regarding dnsmasq's hostname in dnsmasq's configuration. So, regarding the A record, this is all that I know:

$ dig jupiter 

; <<>> DiG 9.9.3-rpz2+rl.13214.22-P2-Ubuntu-1:9.9.3.dfsg.P2-4ubuntu1 <<>> jupiter
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28464
;; flags: qr aa rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;jupiter.                         IN      A

jupiter.                  0       IN      A

;; Query time: 1 msec
;; WHEN: Wed Jan 15 22:39:19 EST 2014
;; MSG SIZE  rcvd: 39
  • What A record for jupiter set in the zone file of DNS server? – VL-80 Jan 16 '14 at 3:38
  • Thx. OP updated. – xpt Jan 16 '14 at 3:43
  • So, your DNS server is returning on request to resolve jupiter. That is why nslookup shows Now we need to set correct A record for name jupiter. – VL-80 Jan 16 '14 at 4:03
  • and to do that with dnsmasq...? – xpt Jan 16 '14 at 4:07
  • Well I am not familiar with dnsmasq, but I looked at Wikipedia article about it. It looks like it just forwards data to/from real DNS server. How is your network setup? Do you have any DNS server? Or dnsmsq is only thing of this sort you have? – VL-80 Jan 16 '14 at 4:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.