1

I have N1 and N2 network. The host has two ethernet adapters E1 and E2. The host is connected to N1 through E1, but I want to connect a guest to N2, and I do not want N2 to affect the host by any means. E2 is not a USB ethernet, so I cannot redirect the adapter to VM directly.

I followed the instruction on this page. The page says uncheck everything on E2 except the VMware Bridge Service. But I found that if I do not also check IP4, the guest gets no internet connection. Is there any way to achieve what I want, without enabling IP4 on E2? Because enabling IP4 on E2 would make the host reachable from N2.

  • Disabling all except VMware bridge protocol is the correct way. I've done this several times. I guess there is an issue in your guest OS. Do you have a static IP or DHCP in your guest VM? – nixda Jan 16 '14 at 13:04
  • The guest OS is Windows 7. It was set to DHCP but I also tried static IP. Neither worked. The error message was something like the default gateway is not reachable. Only when IP4 checked, the guest OS seemed to connect to the internet. – Damn Vegetables Jan 19 '14 at 14:37
0

Last I tried that at work, it did not work.

Today I tried that again at home. First I connected with only the Bridge Service checked. The guest could not connect to the internet. Then I checked IP4. The guest could connect to the internet. Now I unchecked IP4 (leaving only the Bridge Service), and curiously, the guest could still connect to the internet. Even after guest reboot, the guest could connect to the internet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.