I already looked for solutions on internet and on this forum but it did not help so posting a new question.

I have windows 7 Professional and i connect to broadband via ethernet (always on). When i connect the cable it automatically assign the private address "169.254.XXX.XXX" with some DNS addresses as DHCP is enabled. I tried the following

  1. ipconfig /renew and /release

    “An error occurred while renewing interface Local Area Connection : The RPC server is unavailable.” while RPC related services are running.

  2. route delete , winsock reset and netsh ip reset and restart

    no change.

  3. Tried in safe mode

    Same problem.

  4. tried in another laptop

    it works automatic DHCP address is assigned and is able to connect to internet

  5. tried dongle usb broadband

    works on my laptop

  • Can you try going to the Services Console (Run prompt and "Services.msc") and see if the "Remote Procedure Call (RPC)" service is started? If it is already started I would suggest trying to restart it to see if that helps. – Sam Jan 17 '14 at 6:37
  • no help .service was already running , no help from restart – user3172833 Jan 17 '14 at 8:51

Go to services in windows 7 via start menu or run command ,type services.msc

since you have tried all of the above i suggest

  1. Check if DHCP client service is running . if not set it to automatic and start .

if still the problem is not solved ,this may be hardware problem and i suggest you to run a diagnostics via windows as well as via any OEM software if you have.


If you get an Access Denied error while trying to start the DHCP Client service:

Use RegEdit to give Full Control to NETWORK SERVICE, LOCAL SYSTEM and <ComputerName>\USERS on the following keys:

  1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp
  2. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\tcpip

And when you do, click on Advanced and select Replace all child object permissions with inheritable permissions from this object

Source 1

Source 2

  • 2
    SE is tha place to find good answers. been looking for a solution for an hour... should have been here faster. – Jonathan Drapeau Feb 14 '17 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.