0

So I rented this server with Debian 7, and wanted to install a webserver, and followed the following tutorial:

http://www.howtoforge.com/ubuntu_debian_lamp_server

And I'm now stuck at the PHPMyAdmin part. Probably the problem is that I tried to install PHPMyAdmin before changing the root password.

So I purged PHPMyAdmin, and currently the problem is that I'm unable to login at all to mysql. So to break it down, the command:

mysql -h localhost -u root -p

asks me for a password, and the password ALWAYS doesn't work. So I started searching for a solution, and found this one here:

http://myotragusbalearicus.wordpress.com/2011/11/21/mysql-error-1045-28000-access-denied-for-user-rootlocalhost-using-password-no/

So I reset the password using the mysql-command

UPDATE user SET password=PASSWORD('YOUR_NEW_PASSWORD_HERE') WHERE user = 'root';

like a gillion times... and the new password never works! I tried also to flush privileges after the password reset... but no use.

Please advise. This is the first time setting my own server.

Thank you for any efforts.

  • did you first kill the mysql daemon – Gaurav Joseph Jan 18 '14 at 11:31
  • @GauravJoseph Of course, and started the safe-mode – The Quantum Physicist Jan 18 '14 at 11:37
  • You might want to try FLUSH PRIVILEGES after the UPDATE command – Gaurav Joseph Jan 18 '14 at 11:59
  • @GauravJoseph I did that... in fact it's mentioned in the post... – The Quantum Physicist Jan 18 '14 at 12:03
  • Did it 3 times now worked every time. – Gaurav Joseph Jan 18 '14 at 12:04
0

Thanks to Gaurav, it works now. It turns out that the default root user name was "admin" and not "root".

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.