0

If anyone can help...

I get the same error every time when I try to install Pydev on Eclipse Indigo using this procedure http://community.linuxmint.com/tutorial/view/864

OS is LinuxMint Release 13 (maya) 64-bit/Kernel Linux 3.2.0-23-generic

ERROR: "Installing software" has encountered a problem. An error occurred while collecting items to be installed

Details:

An error occurred while collecting items to be installed
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Problems downloading artifact: osgi.bundle,com.python.pydev,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile8423629606714641838.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile8423629606714641838.jar
Problems downloading artifact: osgi.bundle,com.python.pydev.analysis,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile8391623327659480311.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile8391623327659480311.jar
Problems downloading artifact: osgi.bundle,com.python.pydev.codecompletion,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile3746625321772103475.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile3746625321772103475.jar
Problems downloading artifact: osgi.bundle,com.python.pydev.debug,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile4902431167943030588.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile4902431167943030588.jar
Problems downloading artifact: osgi.bundle,com.python.pydev.fastparser,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile8336801411655622421.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile8336801411655622421.jar
Problems downloading artifact: osgi.bundle,com.python.pydev.refactoring,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile3401911711333613730.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile3401911711333613730.jar
Problems downloading artifact: osgi.bundle,org.python.pydev,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile5465887325944080639.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile5465887325944080639.jar
Problems downloading artifact: osgi.bundle,org.python.pydev.ast,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile2530886465445907824.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile2530886465445907824.jar
Problems downloading artifact: osgi.bundle,org.python.pydev.core,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile8353668280674205348.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile8353668280674205348.jar
Problems downloading artifact: osgi.bundle,org.python.pydev.customizations,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile8961879712878586747.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile8961879712878586747.jar
Problems downloading artifact: osgi.bundle,org.python.pydev.debug,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile5358033523041732985.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile5358033523041732985.jar
Problems downloading artifact: osgi.bundle,org.python.pydev.django,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile701668588170627706.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile701668588170627706.jar
Problems downloading artifact: org.eclipse.update.feature,org.python.pydev.feature,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile8407261573488726376.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile8407261573488726376.jar
Problems downloading artifact: osgi.bundle,org.python.pydev.help,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile7258747189504801082.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile7258747189504801082.jar
Problems downloading artifact: osgi.bundle,org.python.pydev.jython,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile8306438291183972232.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile8306438291183972232.jar
Problems downloading artifact: osgi.bundle,org.python.pydev.parser,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile6196297495782026099.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile6196297495782026099.jar
Problems downloading artifact: osgi.bundle,org.python.pydev.refactoring,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile1002743366551160316.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile1002743366551160316.jar
Problems downloading artifact: osgi.bundle,org.python.pydev.shared_core,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile281611419680518255.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile281611419680518255.jar
Problems downloading artifact: osgi.bundle,org.python.pydev.shared_interactive_console,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile6543277695859229447.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile6543277695859229447.jar
Problems downloading artifact: osgi.bundle,org.python.pydev.shared_ui,3.2.0.201312292215.
Error reading signed content:/tmp/signatureFile6214006044667779893.jar
An error occurred while processing the signatures for the file: /tmp/signatureFile6214006044667779893.jar
3
1

This question has been answered in SO: https://stackoverflow.com/q/19916925/210336 (a number of unmarked duplicates exist there actually, this is the oldest one I could find).

Excerpt from answer:

from: http://pydev.org/manual_101_install.html

Important requisite

PyDev now requires java 7 in order to run. If you don't have java 7, the update process may appear to succeed, but PyDev will simply not show in the target installation. Please double-check if you're using a java 7 vm in about > installation details > configuration before trying to install PyDev.

Eclipse 3.8 onwards is required for the latest versions of PyDev (if you need to use an earlier version of Eclipse, stick to PyDev 2.8.x).

Which version of Eclipse are you running? I'm running Ubuntu 12.04 and the Software Center serves me Eclipse 3.7.

To install 2.8.x in Eclipse, do as bohrax mentioned: unselect "Show only the latest versions of available software" and select the 2.8.x.

(PS: how to handle cross site duplicates)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.