35

I Recently uploaded a .PSD file from work to my personal Google Drive so I can download and work on it at home. Today when I went onto my Google drive to download this file, when I pressed the download button, Drive opened another tab in my browser with an Error 403 "Forbidden" on it. I tried downloading some other files, and none of the other .PSD files on my drive would download either; They also gave me an Error 403. All of my other files were able to download, though.

I do not know why I am all of a sudden not allowed access to my files as this was working just the other day. It seems awfully silly that I am forbidden to access my own files. Is there a workaround for this or am I just going to have to send a disgruntled email to Google about them restricting my access to my files?

9
  • Just spitballin' - Is it possible that Google Drive is preventing the download because you don't have a registered file reader of some type on the target system? Allowable to upload, because the correct application is registered there, but no reader here?
    – wbogacz
    Jan 19, 2014 at 3:00
  • Are you able to do other things to the file? (Move, copy, share ?) Jan 19, 2014 at 3:42
  • @wbogacz If you are saying it won't let me download because I don't have the software to use the file, that is incorrect, as I have Photoshop, which opens .PSD (photoshop documents). If you are saying that it is because Google drive does not have the right reader to open the file, this is also incorrect as Google can natively open .PSD Documents. Thanks for the reply though~ Jan 19, 2014 at 4:23
  • @BrianAdkins Yes, I can do all of those things that you mentioned. Jan 19, 2014 at 4:23
  • 1
    Possible similar issue here with google drive and psd files : productforums.google.com/forum/m/#!topic/drive/hTSJoK5AIAk Jan 19, 2014 at 19:35

10 Answers 10

46

Try logging out of all other users in your web browser or use Incognito Mode if your browser has it (which has the effect of doing this). Kudos to Ahmad for saving me with this answer today!

As he clarified (and glenviewjeff and Boynux both suggested in the comments to the OP), either of these approaches seem to help because of a bug with multiple user sign-in. It doesn't even matter if all the accounts signed in are granted permission to download the file; it's something about having more than one account signed in.

I had this happen today with .xlsx files in both Chrome and IE11. In IE11 I saw the same behavior as the OP described here:

"when I pressed the download button, Drive opened another tab in my browser with an Error 403 "Forbidden" on it. ... They also gave me an Error 403."

In Chrome the behavior was a little different (it opened a download window prompting me to save a file with a long string of random numbers and letters and no file extension; clicking save returned a "Failed - Forbidden" message in the download tray at the bottom), but the result is the same as the OP's subject line: Google Drive won't let me download my files.

6
  • 1
    Interestingly, I could upload a file, but got forbidden (status code 403) downloading that same file right after the successful upload. Signing out of the second account that was logged in solved the problem. Definitely a bug somewhere.
    – sootsnoot
    Oct 2, 2017 at 18:01
  • 4
    December 2018 and this is still a bug :(
    – ffledgling
    Dec 15, 2018 at 5:22
  • 2
    March 2019 and it's still a bug. Using latest Chrome browser & Windows 10... can't download a PDF I just uploaded.
    – Martin_W
    Mar 20, 2019 at 1:01
  • 1
    June 2019—Chrome & macOS, though I don't expect that most platforms matter here.
    – James Wang
    Jun 18, 2019 at 19:35
  • 1
    It happened to me because I was signed in into the Chrome browser with a different account than the one I signed in with to access Drive.
    – Zimano
    Jul 2, 2019 at 18:50
9

This works for me: Right click on the file, then click on Create shareable link and use that link.

3
  • good idea! Another one is to select another file with it (it creates zip for multiple files, but it's very slow)
    – JinSnow
    Dec 24, 2016 at 14:31
  • Doesn’t this change the security settings of the file so that anyone with the link can view it? Jul 4, 2018 at 15:31
  • @MatthewLeingang It does, but it's of no concern if you don't spread the link.
    – Zimano
    Jul 2, 2019 at 18:52
8

If you have multiple Google Drive accounts, try downloading in a separate browser or in Incognito Mode.

For Chrome, the shortcut is Ctrl+Shift+N.

4
  • It isn't clear how using Incognito Mode would solve the problem described by the author.
    – Ramhound
    May 19, 2016 at 17:37
  • cause there is some bug or just restriction by Google drive which won't allow multiple drives on single PC. Incognito Mode hides the fact that you are using multiple drives on a single PC. Try it
    – Ahmad
    May 20, 2016 at 5:13
  • I did try it, I then read the question, and don't see how the two connect
    – Ramhound
    May 20, 2016 at 11:56
  • well works perfectly for me... everytime
    – Ahmad
    May 21, 2016 at 7:25
4

I found a workaround/solution to the issue without having to log out of other Google accounts. It seems that there may be an interaction between blocking third-party cookies, multiple Google account logins, and Google Drive downloading.

Kudos to Venkat Aduri on the Google Drive help forum who came up with a more reasonable workaround besides logging out of all of your accounts and/or going incognito.

Just open Drive on a new tab, click the lock, then the blocked tab, and either "allow" or my personal preference, "clear on exit."

screenshot

1
  • Sorry, I posted my reply before I read your solution but you are correct. It appears to be related to third party cookies being blocked. In my case I unblocked them and downloads resumed. Jan 11, 2021 at 10:00
1

If you are signed in using multiple account on the same browser, try to logout it first and login again. It works for me.

1
  • Incognito Mode didn't work for me but logging out of my other accounts did, thanks! May 28, 2019 at 20:18
0

try to make a copy and download the file.
Before that check the access privilege in sharing.
check whether download option is ticked or not.

0

The too many users logged into the same browser was the cause of my issue. Rather than log them all out I just selected my name in the very top right of the Chrome browser and selected Guest from the dropdown. This opens a guest user browser and then I logged into the Google Drive account and was able to download the file not problem.

0

The multiple signed in account problem still exists as of today. Instead of incognito or use different browser, you can have multiple profile within Google Chrome, just switch to the profile with the google account you want to use.

0

Use GDrive Direct Download URL Maker is a quick workaround, if you need your Gdrive files now

0

As @glenviewjeff states the issue relates to blocking third party cookies. In my case I re-enabled third party cookies for all sites and downloads resumed but you might want to try @glenviewjeff's solution first.

I'm logged into a work and personal account and tried logging out of all accounts on all devices to no effect and a lot of hassle re-logging in everywhere. Then I tried the suggested workaround of sharing the file or folder in question, downloading via the sharing link and then unsharing which works.

Yesterday when I attempted to download a file a Google Chrome message popped up telling me to enable third party cookies which I had disabled. I did so and it fixed it immediately. No more failed downloads.

I'm guessing Google found the cause and added the notification.

Not the answer you're looking for? Browse other questions tagged or ask your own question.