{Fwbootmgr} skips {bootmgr}

I used bcdboot C:\Windows /l en-gb /s B: /f ALL from bootable USB when ASUS K55A - HI5014L magically corrupted boot information when multiple f1-12 keys were pressed at a start up. I was able to boot into win7 64bit, one of two OSs in dual-boot setup. I then recreated bootentries for {bootmgr}. However every time i restart system continues just boot straight to win7. I can't figure out how to link fwbootmgr to bootmgr.

I have tried Bcdedit /set {FWbootmgr} displayorder {Bootmgr} /addfirst

I couldn't find any info on google as to what will happen if I delete fwbootmgr, however it is an option in "Visual BCD Editor"

C:\Users\Administrator>bcdedit /enum firmware

Firmware Boot Manager
identifier              {fwbootmgr}
displayorder            {bootmgr}
timeout                 15

Windows Boot Manager
identifier              {bootmgr}
device                  partition=\Device\HarddiskVolume2
path                    \EFI\Microsoft\Boot\bootmgfw.efi
description             Windows Boot Manager
locale                  en-us
inherit                 {globalsettings}
default                 {default}
resumeobject            {9090be92-4d7c-11e3-b2e3-08606e0fb7bc}
displayorder            {default}
toolsdisplayorder       {memdiag}
timeout                 15

Firmware Application (101fffff)
identifier              {9090be8e-4d7c-11e3-b2e3-08606e0fb7bc}
device                  partition=\Device\HarddiskVolume1
path                    \EFI\Microsoft\Boot\bootmgfw.efi
description             Windows Boot Manager


Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
----------  ---  -----------  -----  ----------  -------  ---------  --------
Volume 0     A   SYSTEM       FAT32  Partition    300 MB  Healthy    System
Volume 1     D   Win8x64      NTFS   Partition     93 GB  Healthy
Volume 2     C   Win7x64      NTFS   Partition    249 GB  Healthy    Boot


When I tried to set partition to ACTIVE and got an error I learned that GPT do not use Active partition. All my partitions are GPT. Also read that MBR is not related to EFI.

After messing around with bcdedit bootrec and bcdboot earlier today... I completely locked myself out. System wouldn't boot, bcdedit of a USB couldn't find data. Bootrec /rebuildbcd was identifying two installations but said "The requested system device cannot be found." bcdboot d:\windows "failure when attempting to copy boot files"

I tried to do repair of win8 USB got "required file is missing or contains errors" file: \windows\system32\winload.efi

so I cheated and used EUFI modded USB installation to install a second w7

I now have Working Windows Boot Manager that i can add entries to. But when I use EasyBCD to add simple entry like

Name: w7 BCD ID: {be824de0-829d-11e3-bafc-f6ea108bac12} Drive: F:
Bootloader Path: \Windows\system32\winload.exe

the system hangs on start up..

My BCD files may be corrupted

Another Edit

I can see now what EasyBCD did wrong it added entry with winload.exe ... changed that to winload.efi and now I can boot to original w7, next tried to do that with w8 but get "windows cannot very the digital signature of this file"

BTW looked at diskpart, w7 install created a new fat32 system partition, my old 300 mb fat32 at some pointed turned into primary losing its system to a 900mb partition that came out of nowhere... so that my have contributed to mayhem...

DISKPART> list vol

Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
----------  ---  -----------  -----  ----------  -------  ---------  -------
Volume 0     A   SYSTEM       FAT32  Partition    300 MB  Healthy
Volume 1     D   Win8x64      NTFS   Partition     93 GB  Healthy
Volume 2     C   Win7x64      NTFS   Partition    249 GB  Healthy    Boot
Volume 3     E                NTFS   Partition    102 GB  Healthy
Volume 4     F   Restore      NTFS   Partition     20 GB  Healthy
Volume 5                      FAT32  Partition    100 MB  Healthy    System

Booted into EUFI win7 USB, bootsect went thru, but bcdboot and sfc got rejected. enter image description here

I tried label command inside \system32\ and it gave me "invalid win32" but if I ran it off C:\Users\Administrator> it'll go thru so how do I run bcdboot or sfc and have it work on specific partition because my thinking is going into \system32\ on D: partition would isolate commands used to that partition and OS.

And for offline sfc scan the /offbootdir should be the fat32 100mb where EFI is or I'm seeing thru partition manager there is also "Microsoft Reserved" 128mb is what I should have selected.

enter image description here

  • Which partition is EFI System - 1 or 2 ? In Windows 7 issue the command bcdboot Q:\windows where Q: is latest OS installed (Win 8?)
    – snayob
    Jan 19, 2014 at 10:59
  • @snayob you may be on to something... bcdboot goes thru successfully but no result at startup i also tried with /s d: which threw an error .. ill attach image to show you. I looked in Disk Management and have EFI System Partition 900mb, which wasnt there before, with DISKPART i learn its on Partition 2 as System. I tried to set the other FAt32 Volume 0 System thats (System, Primary Partition) 300 mb to be active i got "The selected disk is not a fixed MBR disk" Im trying to learn as I go along Jan 19, 2014 at 16:09

2 Answers 2


So after your update.

EasyBCD only displays UEFI BCD because it redirects bcdedit output but cannot create UEFI loader entries.

  1. Boot any 64-bit Win 7/8 USB/DVD using UEFI boot !!!

  2. Find Windows 8 drive letter. Assuming it is Q.

  3. Change to Q drive, Then cd \Windows\System32.

  4. Fixing MBR is not an empty operation as MBR must be a "protective MBR" for GPT disks. bootsect /nt60 all /force /mbr

  5. bcdboot Q:\windows /s Q: /f UEFI

if bcdboot fails it means that the copy of system boot files kept in Windows 8 are damaged and you should repair Windows 8 which can be done offline using "sfc" command. google "sfc offline" for exact syntax or "sfc /help"

This should fix Windows 8 booting and preserve existing Windows 7 entry.

  • thanks for you help, posted results in original question. Jan 22, 2014 at 6:15
  • Can you still boot to Windows 7 ?
    – snayob
    Jan 24, 2014 at 1:39
  • If so, you can do: 1) map EFI System with mountvol to S: 2) copy BCD to BCD.old 3) delete BCD 4) backup current boot managers 5) delete boot managers 6) boot from WIN 8 USB/DVD and run bcdboot => it will create new BCD and copy correct boot managers to EFI system. 7) you can always go back using BCD.old and bootmgrs.old .... boot managers are in "S:\EFI\Microsoft\Boot" - bootmgfw.efi + bootmgr.efi
    – snayob
    Jan 24, 2014 at 1:55
  • If you need guidance for commands: "del" is delete, "ren" is rename, "copy" is copy. Steps (2 + 3) repeated for BCD, bootmgfw.efi and bootmgr.efi. You can post also a question on boyans.net/forum.html for further help.
    – snayob
    Jan 24, 2014 at 2:10
  • UEFI Boot sequence is 1)firmware -> 2)first entry in NVRAM "BootOrder" -> 3) in case it points to bootmgfw.efi it is booted and then bootmgr.efi is booted which reads BCD and displays boot menu.
    – snayob
    Jan 24, 2014 at 2:27

To correct booting:

  1. You don't need "SYSTEM" (300MB) partition. Delete it completely using disk management.

  2. Delete the object with GUID {9090be8e-4d7c-11e3-b2e3-08606e0fb7bc} using bcdedit.
    All boot related files for UEFI are on EFI-System (BCD and bootmgfw.efi + language files)

  3. Update contents of MBR
    d:\Windows\System32\bootsect /nt60 ALL /force /mbr

  4. Update BCD
    d:\Windows\System32\bcdboot d:\Windows

  5. Reboot.

  6. Check in firmware UEFI boot sequence - Windows Boot Manager should be listed first and boot be should be UEFI enabled.

Let's hope this will fix boot issue.

  • my reply was to long so i put in the original question. Jan 21, 2014 at 14:14
  • Wait, wasn't bootsect only for Legacy BIOS booting method? Dec 15, 2020 at 14:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .