0

I have Patriot micro SDHC 32GB class 10 memory card. I use it only for saving pictures and videos taken with my phone (Galaxy S3 GT-I9300, CM 10.2 stable) and for saving music too. Basically all large files (movies, app(s) data, etc., mostly irrelevant), pictures and videos(very important) and music were on this card.

Now the problem is that it suddenly stopped working over night, and couldn't be read in any way. Previously (last 2 months top) it would from time to time suddenly stop working, but ejecting it and inserting it back in would do the trick.

I've tried to eject it and insert it, no results. It wouldn't even recognise it, or it would display an error notification such as "corrupted volume, please format". Usually I could read it normally with my phone or access it via USB cable over my phone and everything was fine. Both system and external memories were useable and accessible.

Then I tried to read it with an USB card reader (http://the-gadgeteer.com/assets/sandisk-microsd-1.jpg), but still nothing. My laptop wouldn't even find anything inserted.

When that failed too I have inserted it into an SD card adapter and then in my laptop's SD card reader (laptop is ASUS G750JX, Win8.1). This was similar to my phone's situation; either not recognised at all, or would show unmounted volume; "please insert drive into volume F".

I haven't tried any recovery software yet, because I'm planning to try with a proper USB card reader. The only thing that I need from that card is folder with taken pictures. I can download music again and other stuff can be downloaded (even though it would be nice if music could be recovered too). Any advice is welcome, so please post any ideas for full or even partial recovery. Literally anything is helpful at this moment. Thank you for your help.

  • 1
    A recovery program I can suggest you is PhotoRec. You could also try reading the SD card from a different operating system, e.g. any Linux live CD. – and31415 Jan 20 '14 at 0:40
1

From your description, it sounds as if it is broken.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.