I'm running Debian 7.2 on an old late 2006 Macbook Pro. I've got two 4 TB Seagate Backup Plus hard drives connected to it that I've got in a mirrored ZFS pool. Recently one of the drives died, and I received a replacement drive that I'm trying to add as a new mirror. However, I can't get it to resilver, as an error inevitably happens before it can finish.

The problem is that this replacement drive seemingly keeps disconnecting and reconnecting within a fraction of a second. What I've found is the following messages being printed in the system log over and over:

Jan 19 20:08:07 thingamadealies kernel: [100555.410370] usb 1-1: USB disconnect, device number 43
Jan 19 20:08:07 thingamadealies kernel: [100555.660059] usb 1-1: new high-speed USB device number 44 using ehci_hcd
Jan 19 20:08:07 thingamadealies kernel: [100555.794444] usb 1-1: New USB device found, idVendor=0bc2, idProduct=a0a4
Jan 19 20:08:07 thingamadealies kernel: [100555.794452] usb 1-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
Jan 19 20:08:07 thingamadealies kernel: [100555.794458] usb 1-1: Product: Backup+ Desk Mac
Jan 19 20:08:07 thingamadealies kernel: [100555.794463] usb 1-1: Manufacturer: Seagate
Jan 19 20:08:07 thingamadealies kernel: [100555.794467] usb 1-1: SerialNumber: XXXXXXXX
Jan 19 20:08:07 thingamadealies kernel: [100555.795636] scsi41 : usb-storage 1-1:1.0
Jan 19 20:08:07 thingamadealies mtp-probe: checking bus 1, device 44: "/sys/devices/pci0000:00/0000:00:1d.7/usb1/1-1"
Jan 19 20:10:46 thingamadealies kernel: [100714.601169] usb 1-1: USB disconnect, device number 44
Jan 19 20:10:46 thingamadealies kernel: [100714.872081] usb 1-1: new high-speed USB device number 45 using ehci_hcd
... etc ...

Sometimes this will happen several times a minute. Occasionally the messages get printed with a few seconds of each other. On other occasions this behavior stops altogether for several hours, or even close to a day. I sort of suspect, but have no proof, that it might be related to when the hard drive is under load.

No other USB or IO errors or other relevant messages are printed to syslog, and I don't know where else I can look for clues.

The other drive doesn't have this problem at all, and has been working great since I got it.

What I've tried so far:

  • switching which USB plugs the drives are connected, to see if the other drive starts having this problem. So far it hasn't but it's only been an hour or two.
  • I've also googled quite a bit, and found other people with similar problems, but none exactly like mine, and I haven't found a solution yet. Most people with this issue at least get some kind of USB error in syslog along with the "USB disconnect" message.

Any help anyone could give me would be much appreciated! I don't really know how to debug a hardware issue like this.


After switching which USB plugs the drives are connected to, the message being outputting to syslog changed to:

usb 1-3: reset high-speed USB device number 4 using ehci_hcd

I've confirmed usb 1-3 is the problem drive. So something is still wrong, but it's a slightly different wrong thing now. So far ZFS hasn't had any errors... hopefully it'll stay that way.

Update 2:

The resilvering has finished! However, I'm still getting the "reset high-speed USB device" messages. I tried switching around the cables between my two drives, but it didn't make any difference, so I think that rules out the issue being the cable.

I've seen some evidence that upgrading my kernel might fix this, so I'm going to give that a shot.

Update 3:

Upgraded my kernel to 3.10, had no effect. Still don't know how to fix this.

4 Answers 4


It's over two years later but I figured I may as well answer this question just in case anyone else ever has the same issue.

It turns out that one of the USB2 ports on this old MacBook Pro was not working properly. Not sure exactly what the issue was, but I ended up buying a USB3 expansion card to get better speed out of the drives, and after using that both drives performed perfectly. This is the first and only time I've ever had a USB port actually be the cause of a problem like this.

  • 1
    CentOS 7 have similiar error with lenovo ThinkCentre. I might need a USB3 port too. I unplug the usb mouse since I use console mode of CentOS usually. It stop showing warnings. usb 4-1.5: USB disconnect, device number 3 usb 4-1.5: new low-speed USB device number 4 using ehci-pci usb 4-1.5: New USB device found, idVendor=17ef, idProduct=6019 ....
    – Nick Dong
    Nov 1, 2016 at 3:45
  • Anyone has an idea how to tell whether it's the port on my motherboard or the wire that's to blame? Besides swapping out wires (it's a non-standard shape, would be nice to avoid buying a 2nd) Oct 5, 2022 at 3:13
  • @MichaelChirico You could try connecting a different device to the port and seeing if it has a similar issue. That would implicate the port rather than the cable.
    – Bri Bri
    Oct 5, 2022 at 12:42
  • Oh, duh! Makes sense. Experimenting now. Oct 5, 2022 at 14:47

Maybe the replacement drive isn't exactly identical and requires a bit more power. Disconnecting and reconnecting is typical for underpowered drives. Try to connect external power source if the disk's enclosure supports it.

  • 1
    Both drives have their own power source, plugged into a wall outlet, so I don't think it's that. But thanks for the suggestion.
    – Bri Bri
    Jan 20, 2014 at 14:52

This "Seagate Backup Plus" is an external disk enclosure, right? The disk might be OK but maybe it's the enclosure's fault? Or the USB cable is bad. If you haven't changed anthing else (kernel upgrade?) since the older disk died, I'd suspect a hardware problem. Without attempting to import the disk to the ZFS pool, can you dd from the disk from start to end w/o errors?


I had a similar problem.

I went for a hard solution: getting an internal SATA drive and no longer be at the mercy of USB issues.

Perhaps this is also cost effective for you, your time is valuable.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .