I've had a router set up for quite some time and it has been working perfectly. My wife called me to tell me the wireless internet wasn't working and when I came home I saw that my phone was connected to the wireless but there wasn't any internet, even though the wired devices had internet. My router is at and gives out the normal IP addresses that you would expect 192.168.1.xxx. The IP address on my phone though was, still in the private network range, but totally nothing that should be assigned by my router. I reset the router, disable and enable dhcp, verified what IP address it should be assigning, but without success. I had another spare router that I wasn't using so I replaced the non-working router with the spare but all the wireless devices are still get the 10.55.142.xxx addresses and no internet connection. So I changed the SSID on my router to make sure someone else wasn't trying to used the same SSID but that didn't changed anything. There are no other router's in my house and nothing I can think of that would try to assign out IP addresses.

The wired connections to the router work just fine, but they all have static IP addresses. So I changed my computer to get an address through DHCP, and it got a 10.55.142.xxx address. If I changed the phone to have a static IP address it works! What is going on! It appears that DHCP isn't working but it can't be the router can it? The router was working and I replaced it with another one with the same results. I'm totally confused on this one.

  • It sounds like you have a rogue DHCP server on your network. You can try disconnecting devices one by one, or a packet analysis tool like Wireshark. – Bob Jan 21 '14 at 5:02

It looks like you have a new DHCP server on your network.

The first thing you should try and see is which gateway you are assigned, when you are on the bogus subnet. If it is in the range, you may probably guess on which computer it resides, since you stated your pcs are all on static IPs.

Or, you may try turning off your pcs one by one, and see when your wireless devices, eventually, acquire an IP address in the range. The last pc turned off is then the culprit.

Or, you may use a Ubuntu installation (drop an Ubuntu image onto a USB stick, and boot from that)to issue the following commands:

    sudo service network-manager stop
    dhcp -v eth0

from an ethernet-connected pc. The output,

   dhclient -v
   Internet Systems Consortium DHCP Client 4.2.4
   Copyright 2004-2012 Internet Systems Consortium.
   All rights reserved.
   For info, please visit https://www.isc.org/software/dhcp/

   Listening on LPF/eth0/e8:e0:b7:be:72:6a
   Sending on   LPF/eth0/e8:e0:b7:be:72:6a
   Sending on   Socket/fallback
   DHCPDISCOVER on eth0 to port 67 interval 3 (xid=0x333a3d1d)
   DHCPREQUEST of on eth0 to port 67 (xid=0x333a3d1d)
   DHCPOFFER of from
   DHCPACK of from
   bound to -- renewal in 35456 seconds.

shows this critical line,

  DHCPOFFER of from

which displays the IP address of the pc making the offer (, in my case).

Or, assuming these IP addresses don't mean a thing (i.e., they fall in the range), you may try installing a program called nmap, and run it with the command

  nmap -T4 -A

where is the gateway your pc is assigned, if it is not please change it to its true value. This will tell you many things about the host pc, including (if you only have Windows machines) its name.

This should at least identify the pc where the new DHCP server is running.

  • Thanks for the wonderful answer. Unfortunately the problem went away on it's own, but I think you are right. I forget that the Ooma phone that I have can behave like a router and I think it must be the culprit. It has been in the network like this for years without misbehaving but something must have been off yesterday. I'll pull this back out when it happens again to make sure it is the Ooma phone. I've tried it out and it will definitely help me find who is assigning IP address. – kfrance Jan 22 '14 at 2:24

I was experiencing something very similar. In my case (we have three routers in the house) the problem was that someone had changed the port of an Ethernet cable on one of these routers from the incoming WAN port to one of the outgoing ports. This made the whole network go crazy.

You might want to check your cable connections to see if you are in such a situation.


The only possibility I can think of makes sense in this scenario makes sense, but only for one device, not multiple devices. It is possible that you manually set the IP address on your phone to While manually setting the IP address, you didn't set a gateway (or a valid gateway), which would cause you to have a weird private IP address, while not being able to connect to the internet.

The first troubleshooting step I would take is rebooting the phone. The second would be to ensure DHCP is being used on your phone. The third would be to manually set the IP address, subnet mask, and gateway on your phone. Once you finally got your phone working, maybe this would shine some light to what is going on.

  • So the phone can connect to the network if I use a static IP address. So it has to be DHCP that isn't working. The router will show the devices with the weird IP addresses on the list of wireless devices connected wh – kfrance Jan 21 '14 at 4:48
  • It appears that you stopped typing midway through your comment. Is the problem fixed now or are you having issues understanding DHCP? – David Jan 22 '14 at 5:57
  • The problem is fixed. I'm not sure why my comment it cut off half way through. I was trying to say that the router had the devices listed as connected even though they had the weird IP address. – kfrance Jan 22 '14 at 13:24

In case anybody is still puzzling over this post, which very accurately and elegantly frames the problem, I found a fix.

The "rogue" DHCP server in my case was the SIM data connection on my phone. Of course, this must use some form of IP address as it allows my phone to connect to the internet and uses a weird 10.xx.xx.xx format. When I turn off SIM data I get a 192.168.1.xxx address as expected from my router DHCP server.

I can still make calls, but just not use my phone data connection - not a problem if the router is connected to the internet !

  • Phones usually only use cellular data if you have no - or a bad - Wi-Fi connection. There's usually a settings to force the phone to always use Wi-Fi when connected to a wireless network. – Mikael Dúi Bolinder Jan 5 '18 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.