I've installed hyper-v on windows 8, downloaded and added virtual machine from ms site "Windows 7 IE 8". But I can't use mouse, see message in bottom of window "Mouse input not captured". "Action->Insert Integration Service Setup Disk" and reboot doesn't help, "ctrl+alt+left arrow" doesn't help. What's the problem?
upd: I tried this http://blogs.msdn.com/b/dau-blog/archive/2012/02/28/mouse-not-captured-in-remote-desktop-session-when-virtual-pc-vhd-file-runs-in-hyper-v.aspx but after 'starting windows' mouse goes away.


3 Answers 3


Steps to resolve this problem:

  1. go to virtual machine
  2. go to control panel-> programs and features
  3. remove "Virtual PC Integration Components"
  4. shut down and turn on virtual machine

You have to do all these steps using keyboard. Tab is your best friend here.

  • Had same problem with IE8 test VM on Windows 10, and this worked for that too.
    – Ian
    Aug 22, 2015 at 16:47
  • This worked for me using Hyper-V in Windows 10 on a Windows-7 VM. I had to keyboard drive the Win7 virtual machine to do the uninstall. After the un-install and a reboot it started working again. Anyone know why?
    – John Dyer
    May 19, 2016 at 13:43
  • 1
    @JohnDyer most likely because the image you are using was made for use with VirtualPC (NOT HyperV). You can download the hyperV images from modern.ie.
    – joedotnot
    Aug 13, 2016 at 14:17

In case anyone comes across this:

On Windows Server 2008 32bit you need to install SP2 for Hyper-V connectivity (You won't have mouse integration or networking upon base install, and you can't install the Hyper-V integration CD without SP2) Installing SP2 via mounting a CD ISO is easiest (the ISO is named mu_windows_vista_sp2_x86_x64_ia64_dvd_x15-39754.iso on MSDN) Note: Windows Server 2008 R2 64bit does not have this problem, but I couldn't find R2 32bit on MSDN.

If you don't have MSDN I imagine you could get an offline install for SP2 and "burn" it to a virtual drive to create an ISO.

PS - It was fun trying to do things in the virtual console without keyboard shortcuts like Alt+Tab


Uninstalling "Virtual PC Integration Components" in the virtual machine solved it for me as well. One addition though: when uninstalling it asked for the installation cd/files. To tackle this do the following:

-Locate the iso file you originally used to install the integration features;

File name: IntegrationComponents.iso

Probable location: C:\Program Files (x86)\Windows Virtual PC\Integration Components\

-In Hyper-V Manager select the settings for the virtual machine. Insert IntegrationComponents.iso into the virtual cd/dvd station via Hardware ; IDE controller 1

-(Re)uninstall "Virtual PC Integration Components"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .