0

I use the gksu nemo (because my file explorer is nemo) command, yet when I go to the drive I use, I right-click, then go to properties I still cannot change the Permissions.

I have a 1TB portable hard drive, I partitioned it as 3 drives, one is like 100GB and it is ext4 for the OS, and the other is like 770 something GB and NTFS partition and I use that as main storage so I can access it on a Windows if I need to. The third is for Ubuntu and is only 100GB but I don't need to be able to write off that. I can write to it just fine, but Steam says I need to mount it with executable permissions so even though it says I do, I can't use Steam with it. I seem to not be able to execute files in general from it. I have to copy the files to the main OS partition in order to run them.

Am I doing something wrong?

/dev/sdc1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfsd-fuse on /run/user/donnie/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=donnie)
/dev/sdc4 on /media/donnie/Ubuntu Linux type ext4 (rw,nosuid,nodev,uhelper=udisks2)
/dev/sdc2 on /media/donnie/Donnie's Drive type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)

Donnie's Drive is the one I am trying to be able to mount and use steam.

The Ubuntu drive is just an empty 100GB partition on the drive I am going to use to install Ubuntu to.

Thanks everyone for your help. Once you told me it was an issue with the mount I looked into how to fix the NTFS partition mount in linux, I found an extension to install through the software manager and ran it, then I could tell the system to give read and write permissions to the drive. So thank you guys for all your help, I have fix the problem.

  • 1
    Please post the output of mount with the drive connected. – terdon Jan 21 '14 at 19:11
  • Please edit your question to add additional information, it is hard to read and easy to miss in the comments. – terdon Jan 23 '14 at 3:55
0

You need to modify mount options, not permissions, for that drive/partition and make sure that one of the mount options is exec. You should be able to find all your drive mounts in /etc/fstab file. It should look something like this:

/dev/sda6 /media/MEDIA7 ntfs-3g defaults,user,locale=en_US.utf8,exec,uid=1000,gid=1000 0 0

Don't just blindly copy/paste this line. Make sure it matches your system's partitions, device names and uid/gid.

0

First, using NTFS for your steam directory on Linux is a VERY bad idea.

The permission system in windows is incompatible with that in Linux, and this leads to breaking games installed in Linux any time they are accessed in Windows and visa-versa.

You should instead use ext2 and install one of the several ext2 drivers available for windows if you absolutely must also access the drive from Windows, or better yet not install your Linux games on the same partition as your Windows games.

As of changing the permissions for an entire drive, that must be done with either the mount command itself or in the fstab which the mount command reads additional options for the filesystem from.

Still, I will repeat myself, you don't want to run any executable commands from your windows partition. It's a bad idea on so many levels.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.