I installed Ubuntu 12.0.4 LTS to a 2TB Sata with a swap partition and a data partition.

I installed mdadm and setup an incomplete raid. I later unmounted that raid (to which it erred as non-existent) and I uninstalled mdadm. There is no mention of md# in fstab or mount.

I shared a bunch of stuff in my etc/samba/smb.conf.

I then clonezilla'd the drive to an identical drive, and I mount the data partition of the second drive as /mnt/sdb1 in the etc/fstab file.

I wrote some rsync scripts into the cron.d folder (rsync /home to /mnt/sdb1/home, /etc to /mnt/sdb1/etc, /var to /mnt/sdb1/var), and echo the outputs of these rsync to a file in my home folder just so that I know they are running. Some of these echos change every 10 minutes, some every hour.

This was working fine for a few days, so I decided to move the server into the server room.

When I turned it on, I noticed that my rsync echo files were missing, my fstab was original, and my data was 4 days old. I thought that somehow sdb1 became sda1 and that my backups were not working, so I disconnected one, then the other, but the same result.

I was getting frustrated in the server room, so I took the machine back to my desk where I set it up initially, and all of the data returned. I called it a day after that.

It seems to me that there might be multiple mount points on the main partition. Is that possible? My fstab uses /dev/sdba1 instead of a GUID for the file system.

Could the dhcp server have something to do with the mount point? That's pretty much the only difference in the booting environment between my desk and the server room.

Can somebody please help me to understand what happened?

Thank you.


Ok I got it worked out. Here is a synapses:

I did a Clonezilla from my good install to a blank drive.

I then booted to one drive, and mounted the other drive under /mnt/sdb1.

I then wrote an rsync script that does my backup, and set it up to run in cron.d.

I rebooted a couple of times, a few days between.

Everything was working fine until I got a hair-brained idea to tweak my fstab to boot to sda instead of to the UUID of sda, and to add a secondary mount to sdb instead of the UUID of sdb.

Now when I boot, and sda happens to detect first, everything works fine.

But... when sdb detects first, it will boot, and all of the rsync stuff will go to a directory /mnt/sdb1 instead of a mount there.

What I needed to do was, after clonezilla, rename the UUID of sdb, and mount (if not already) sdb1 under /mnt/sdb1, and then I can run successful rsync backups to the other drive. Occasionally, I will run a full backup, but I run a /home, /etc, /var backup every 10 minutes, which takes about 15-25 seconds.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.