I've hit upon a strange issue with a new installation of CentOS 6.5 while trying to install MariaDB.

I've included the following information and created a MariaDB.repo file inside the /etc/yum.repos.d/ folder:

# MariaDB 5.5 CentOS repository list - created 2013-08-11 14:22 UTC
# http://mariadb.org/mariadb/repositories/
name = MariaDB
baseurl = http://yum.mariadb.org/5.5/centos6-amd64

Then, I enter the command yum repolist all, and it shows that this repo is enabled.

However, I then enter this command: yum -y install MariaDB-server MariaDB-client

This outputs the following:

Loaded plugins: fastestmirror, presto, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirror.simwood.com
 * extras: www.mirrorservice.org
 * updates: mirror.synergyworks.co.uk
Setting up Install Process
No package MariaDB-server available.
No package MariaDB-client available.
Error: Nothing to do

I've rebooted the server and ran the command again and this error message still persists. What's going on?

  • Add enabled=1 to the file in /etc/yum.repos.d/ which defines this repository? Also, ensure the capitalization of the package names is correct; yum is case-sensitive. – DopeGhoti Jan 21 '14 at 22:36
  • I've added enabled=1 and typed the package name in both lower and uppercase, and it still can't find the packages. – mickburkejnr Jan 21 '14 at 22:39
  • Perhaps try the full package name, MariaDB-5.5.34-centos6-x86_64-client and -server, as seen here? – DopeGhoti Jan 21 '14 at 22:42
  • I've tried that, and it still comes back saying it can't be found. – mickburkejnr Jan 21 '14 at 22:45

Issue the command: yum clean all

This happens because yum didn't get the new packages list from the repo server. Usually it's preceded by a message

Yum Error: "Not using downloaded repomd.xml because it is older than what we have"

Cleaning yum cache will force it to redownload the packages list, and consequently, recognize the packages.

If this doesn't help, you could also try cleaning some cache in rm /var/cache/yum/.....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.