When I download some files I am unable to open them until I right-click, choose Properties and click the Unblock button (see the image in this post: The file came from another computer and might be blocked).

I have read that this is intended behaviour for security reasons, but would like to disable this feature PC-wide so that it never happens.

I haven't found a solution to the problem at all for Vista Home edition. In the Pro edition there is the utility gpedit.msc. This doesn't work on the Home version.

I changed the registry with the answer given in this thread but it didn't have the desired effect. If not a utlity, can anyone clarify why the registry fix wouldn't work for Vista Home? And if possible give some suggestion to try and fix this issue. Thank you.

Interestingly, this only happens when I download the file with FireFox. If I use Internet Explorer it doesn't happen.


Firefox has its own setting for that (which was recently changed, I think in Firefox 26). If you have Firefox 26 or newer, follow these steps:

  1. Type "about:config" (without quotes) in your address bar.
  2. Confirm the warning message.
  3. Search for "savezone" (without quotes).
  4. Disable the setting "browser.download.saveZoneInformation" by double clicking on it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.