8

Whenever my Jenkins gets notified about a new git commit to my repository foo, I get the following log/error response on the triggering client:

Scheduled polling of foo
No git consumers for URI ssh://git@localhost:9777/path/to/foo.git

This failed notification does not commence building. Using the manual "Build Now" commences building successfully.

Setup

  • I have the Jenkins instance listening on localhost:8666.
  • I have the SSH daemon listening on localhost:9777.
  • Within Jenkins, I have a git-based Maven project:
    • "Maven project name" is foo.
    • "Git Repository URL" is ssh://git@localhost:9777/path/to/foo.git.
  • In that bare repository, I have a hook file hooks/post-receive with content:

.

# this is file post-receive
curl http://localhost:8666/git/notifyCommit?url=ssh://git@localhost:9777/path/to/foo.git

This building-on-commit-notification used to work well. I have the feeling that it stopped working well once I moved from standard SSH port 22 to non-standard 9777.

What do I have to do to have a commit notification result in a successful build trigger?


Possibly relevant source code files:

5

Things to remember when connecting an hook to Jenkins:

  1. Thick the Poll SCM option in the Build Triggers leaving the "schedule" textarea empty

  2. the url=xxx parameter must match the "Repository URL" specified in the job configuration. If it is prefixed by ssh:// you should keep it in the notification call

  3. Don't forget to push a change to the repo you configured! To verify you have changes: http://jenkins-url:jenkins-port/job/JOB-NAME/scmPollLog/ should contain "Changes found" in the last line.

Source: Git plugin docs

  • 2
    #3 is more important than it seems. Check that you pushed to the correct branch if your job is not configured to build every branch. At least that’s what had me searching for an error for the better part of two hours. And even though the build job is triggered successfully, I still get the “No git consumers for URI” message when pushing. – Bombe Oct 15 '14 at 14:09
  • I have still some piece missing. My "jenkins-url:jenkins-port/job/JOB-NAME/scmPollLog" says "Changes found", but I still get "No git jobs using repository: URL and branches:" :-(. I even installed Poll SCM plugin. – pevik Nov 4 '15 at 16:41
0

I was stuck with the same thing.

The problem is that their is no change in your git since the last build. Just make some changes and then use the jenkins notify URL, it will work.

I used:

http://<jenkins-server_link>/git/notifyCommiturl=http://<gitrepo>.git
-1

You don't need the ssh:// part.

try with:

curl http://localhost:8666/git/notifyCommit?url=git@localhost:9777/path/to/foo.git

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.