2

I have a Win 7 Homegroup setup between 2 computers. Both computers have wired and wireless connections to the network and the wired connection is considerably faster for Homegroup transfers (about 8x faster for me). Yet, when either computer has their wireless adapters enabled, the transfers happen over the wireless connection despite it being slower. I've confirmed this because I can disable the wireless on both machines and the speeds go back up. I've confirmed that both machines have the wired interfaces/adapters listed higher in the adapter list and they have lower metrics than the wireless adapters.

What else can I try to ensure that the wired connection is always preferred?

  • If both connections have a wired connection avalible, just disable the wireless functionality, what more do you want other than that? Are you just asking WHY this is happening? – Sickest Jan 23 '14 at 7:27
  • Yes, that "works", but I don't want to have to keep toggling wireless on and off if possible. – Chad Jan 23 '14 at 9:41
  • @Chad since you had already checked metrics and adapter sequencing I figured you already know at least some things about networking and indeed had a unique problem. Have you resolved it? If so I'd like to know just for curiosity. If not, do you have any updates relating to the answer and suggestions I posted? – LMSingh Jan 27 '14 at 23:33
2

The metric is not being used so the most likely cause is that whichever interface is used to make the connection first that interface continues to be used.

You can confirm this theory by having both wireless and wired enabled on initial startup of machines. Then disable wireless test transfer. Then enable and test. This should confirm your current observation.

Now disable wireless, reboot both machines. Retest with wireless disabled and then enabled. I'd venture to guess that now wired will keep being used, even when you enable wireless. If this proves correct then post your findings here and I can provide you two very short batch files that you could run at startup (to delayed enable wireless) and at shutdown to disable wireless.

On a separate inquiry, do both cards have NetBIOS over TCP/IP enabled?

Adding a day later: @Chad This is an interesting puzzle as I've only had to force metrics on interfaces for specific reasons; otherwise automatic metrics have always worked in directing traffic. You're stating that the metrics actually show wired adapter has a lower metric, so in essence you're seeing that metric isn't being used.

Before digging into the puzzle, here's one more solution (if you don't want to spend any more time on this). You can setup your machines to turn off wireless automatically when wired link state is "connected" and turn on when disconnected. Use BIOS setting if available or a utility software free or paid and probably other options out there as well or a setting on your wireless card driver (Intel ProSET cards have it among others). One other thing you can try (it doesn't work on my system but some others have reported that it does).. go into "Control Panel\Network and Internet\Network Connections". If your menus aren't visible, press [Alt]. Select "Advanced -> Advanced Settings". Here move the wired connection up in priority. It doesn't tell you to but people have reported that a reboot is needed after that. That could work for you, though YMMV.

Finally if you do want to dig into the puzzle, here is a list to check

Have you tried to manually set the metrics on both cards in both machines? Does it still not use the metrics?

Another possibility is that TCP/IP is not being used.

Is it windows 7, 64 or 32 bit? If 32 bit, did you by any chance installed NetBEUI protocol?

Brand/model of the router you're using? If NetBIOS over TCP/IP is set to default, does the router's DHCP server disable it or not support it?

Have you disabled "NetBIOS Over TCP/IP" in either card?

Is the "QoS Packet Scheduler" enabled or disabled?

Are you using IP v6 and v4?

Is windows firewall active and enabled on both machines?

Do the wireless cards have any specific setting in the advanced properties where they may make direct connections to each other once they've been authenticated by the wireless A/P?

Is any bandwidth management set on the lan ports in your router?

Can you provide a print of your full adapter list?

From elevated CMD prompt can you run the following commands and provide their output?

netstat -r

netstat -b (close all unnecessary apps prior to running this to keep the list small)

netstat -s

Ref: http://www.infocellar.com/winxp/netbui-netbios.htm

http://www.speedguide.net/faq_in_q.php?qid=350

http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/how-do-you-install-netbeui-protocol-in-windows-7/2a26696b-998a-45fc-a1c0-a8a85af0098d

https://www.google.com/search?q=utility+to+disable+wireless+adapter+when+a+wired+adapter+is+connected

http://accessagility.com/products/bridgechecker.html

http://www.intel.com/support/wireless/wlan/sb/CS-028815.htm

http://sourceforge.net/projects/wifiswitcher/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.