I want to install Windows 7 32bit on Virtualbox (Win7 32bit profile) running on Ubuntu 2013.04 64bit on Lenovo Thinkpad T520.

This usually works fine (and I have installed many Win7 that way with no problem).
But today I get this screen that won't let me go to the next step until I give it some "driver":

A required CD/DVD drive device driver is missing. Select the driver to be installed

I have no idea what driver I should feed it, but I know that Win7 in Virtualbox usually does not need any driver. The fact that the installation is being performed from the DVD drive makes the situation even more ridiculous.

How can I trick the installation into going to the next step?
I actually won't even need to use the CD/DVD driver after Win7 is installed.

  • This has nothing to do with VirtualBox, it is an issue with the license of Windows. Basically, the period during which you could use Windows without registering it is over, and the OS will not let you access the copy you have. I have already seen this happen (not to me, I never use Windows). – MariusMatutiae Jan 23 '14 at 7:49
up vote 7 down vote accepted

I ran into this problem today, you probably already solved your problem, but I'm just adding my experience as it may help somebody else.

(Keep in mind, I used a physical install CD and not an ISO file or any RAR file)

  1. Open your VM settings
  2. Go to Storage
  3. Select the CD-ROM drive
  4. Check Passthrough
  5. Boot the VM with the Windows

Um, it might be a long shot, but it worked for me.

  • 1
    That did the trick, thanks! – Nicolas Raoul Jan 23 '14 at 8:06

Ubuntu 14.04 LTS Trusty Tahr host OS VirtualBox 4.3.10Ubuntu r93012 Windows 7 Home Premium guest

I had the same problem. I first burned the .iso file to a DVD and set up passthrough access to the CD/DVD drive on my Toshiba Satellite C660 laptop. (But you probably don't need to do this. The Windows 7 folder for the VM was created, and the Windows 7 installer started okay. But just after I click Started Setup, a dialogue asks "Where do you want to install Windows?, and displays the virtual VDI volume.

After I clicked Next, a dialogue asked me to select drivers, but the list was blank. When I chose either the DVD .iso or the virtual VDI drive, and alert advised that no drivers were found.

The answer is to change the permissions of /home/<~my-home>/VirtualBox VMs/Windows 7/ and its subsidiary files and folders to Read/Write for owner and group (or even for everybody if it's your own computer). The installer hummed along doing its thing happily.

to solve this problem that i really had the same and i tried alot to solve it... the good answer is to download an iso of windows (your ideal) then go to virtual box setting>storage> there is a plus + sign click on it and choose your downloaded iso . thats it have fun

  • I did this already. Actually this is how I always install Win7 on VirtualBox. The problem appeared even though I had done exactly this. – Nicolas Raoul Oct 13 '15 at 6:02
  • This work to me, actually at first never thought that this will work. – Cary Bondoc Oct 24 at 14:29

Had the same problem. Drove me nuts!! I have a new Debian 8 host and moved my windows guests over from an older machine via USB.

There is a flaw with GNOME. The GUI will show that the .iso has transfered over and that the USB has unmounted when in fact it hasn't. The only way I caught it was that the USB I used to reimage the .iso's the second time had the LED on it and it was still flashing well after GNOME had said the transfer was done.

$ mount

does not show the USB attached and obviously removing the USB corrupted my .iso transfers.

Problem Solved.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.