6

I have just received a Linksys WRT54GC router of a friend. Apparently it has stopped working.

All lights on it are flashing apart from the power and wireless light. I have read of similar issues online but not ones describing the same set of lights flashing. I have tried connecting to the device over ethernet but failed. It's no longer accessible over wireless either.

I've also tried to run the linksys utility on the cd but it failed to detect the presence of the device (attempted over ethernet, firewall switched off).

I've tried pressing the reset button for 30 seconds and disconnection the power cable for 30 seconds but to no avail.

1
2

Sounds like you may have a bricked router. You could try again to hold the reset for longer than 30 seconds, and make sure your computer that you have attached via Ethernet to port 1 of the linksys is set to automatically obtain IP via DHCP.

If the multiple 30 - 60 second resets are not working to bring it back, there is an option of flashing but without some sort of connection to it I doubt that would work either.

5

Your WRT router's power supply is failing. They used low quality capacitors inside it and they became swollen.

The output voltage changed making your router behave abnormally. Try using another power supply for it and it should be fine – if you still have it.

-1

I had the same problem for about an hour late one night. I decided to go to bed and resume working on it the next morning. Everything was working perfectly the next morning. Waiting is undoubtedly not a general solution, but it worked once.

1
  • Could you edit your answer and provide specifics and answer the author's question?
    – Ramhound
    Feb 7 '17 at 3:43
-1

YOu can just usb jtag nt or another solution to restore the whole system through jtag solution, (blackcat, flashcat usb etc)

here is a wiki https://wikidevi.com/wiki/Linksys_WRT54G2_v1.0

1
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – bertieb
    Oct 28 '18 at 12:24
-2

I had the same problem. My power supply was outputting .9 volt instead of 12volt. Replacing the power supply fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.