0

You know, sometimes, if you have, say, Microsoft Word with an unsaved document open and you try to shut your PC down, Windows will tell you that programs are preventing shutdown, and ask you if you'd like to cancel and go deal with the programs or force shutdown. That's a useful feature. It prevents careless mistakes that can have pretty big consequences.

However, my computer has been prevented from shutting down, lately, by file explorer windows. If, say, my Downloads folder is open, and I try to shut my PC down, it will tell me: "The following programs are preventing shutdown: Downloads" (or something similar). This happens even if Downloads is the only thing still open to my knowledge.

I cannot say for sure, but I believe this has been happening since I reformated to upgrade to Windows 8.1. What's wrong?

For reference, I'm using Windows 8.1 Professional, upgraded from a clean install of Windows 8 Professional through the Windows Store.

  • We talking a few seconds or we talking minutes or it entirely prevents the shutdown. If windows explorer is causing this it means something else is not giving up its access to that folder. – Ramhound Jan 24 '14 at 1:16
  • I haven't tried waiting for a very long time, but it's at least 30 seconds. As for what is using the folder... I really don't know what that could be. I think it happens with all sorts of folders. – Ariane Jan 24 '14 at 1:38
  • Try booting without any of your startup programs. See if the problem happens then. You can change what programs start-up through the task manager in Windows 8.1 ( or Google for other methods ) – Ramhound Jan 24 '14 at 1:42
0

Here is a batch file to end task explorer + restart the machine.

@ECHO OFF
taskkill /f /im explorer.exe
shutdown -r -t 0
0

Did the issue occur before? If not, try System Restore and see if the issue can be resolved.

If the issue persists, please first test the issue in Safe Mode (Restart computer, press the F8 key when the boot menu pops up, select [Safe Mode], and boot up) and check if the issue still occurs.

If the issue does not occur in Safe Mode, let's disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

  1. Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

Note: If prompted, please click Continue on the User Account Control (UAC) window.

  1. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

  2. Click the "Startup" tab, click "Disable All" and click "OK".

Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

Please test this issue in the Clean Boot environment, if the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

What is the result?

Hope this helps.

OR

Try installing: http://www.microsoft.com/en-us/download/confirmation.aspx?id=40910

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.