14

When scrolling using the mouse wheel scroll in Google Chrome, there is about 25% chance it would zoom in/out as if I have pressed the Ctrl key.

Disabling my mouse gesture extension reduces the chance to only about 2%.

I have tried various extensions and noticed some mouse gesture extensions seem to make it a bit worse than the others. I am guessing the problem is with Chrome or its extensions.

I believe it is not my hardware or software.

  1. It happens in Chrome on both my Windows 7 desktop computers at work and at home
  2. It never happens in Firefox on either computer (I use both browsers)
  3. I tried turning on "Show location of pointer when I press the CTRL key" so I know if the Ctrl is pressed accidentally - it never was.
  4. I don't have AutoHotKey or anything similar installed on Windows.

Is this a Google Chrome bug? Is there a workaround?

UPDATE:
I installed AutoHotKey to nullify Ctrl+scroll.
Ctrl+scroll now does nothing, but scrolling normally still often zooms.

  • likely duplicate (or, at least, similar solutions) superuser.com/questions/243127/… – michael May 10 '15 at 1:20
  • Posting this as a comment as it's not a solution for everyone: I was experiencing the same issue in Chrome while using my Logitech mouse (M705). The issue for me was that the default assignment of the scroll wheel when [accidentally or intentionally] clicked is to zoom. The solution was to disable this assignment in Logitech Control Center which is the configuration software that can be downloaded from their site. – sparecycle Feb 13 '18 at 15:47
  • The problem itself is not Windows specific. I am looking for platform independent solution. – jarno Dec 20 '19 at 11:29
8

Dont know where from this problem comes. but we can have an alternative solution to that. Depending on the drivers for your mouse, you could set ctrl-scroll as a "shortcut" to actually do nothing - essentially capturing the combination and throwing it away. Some drivers will even let you specify this for only within a certain application, at which point you'd specify chrome.

OR

Another trick would be:

solution using AutoHotKey posted on google groups:

Using Logitech Performance Mouse MX...

Downloaded AutoHotKey software

In the AutoHotkey.ahk file, added these to do nothing for Cntrl+MouseWheelScrolling

^WheelDown::return

^WheelUp::return

http://productforums.google.com/d/msg/chrome/-rtDLZmN9bk/5pJYksjrvQUJ

Also if this doesn't work, please provide some more information about your hardware please..

UPDATE - The solution

It looks like the zooming issue is related to mouse scrolling freeware. I took a look at a tool I run called "WizMouse." The purpose of these tools is to allow scrolling windows without focusing on them. Settings can be changed in these to fix the problem.

Resolutions:

  • KatMouse (per nsx82): Add class: Chrome_WidgetWin_1, and under the settings tick option: "Window has scrolling wheel support?" (try checked first)
  • WizMouse (per JoPa Mi): Uncheck "Enable mouse wheel for applications without mouse wheel support"
| improve this answer | |
  • It doesn't work, interesting... Now I can't zoom anymore by using Ctrl+scroll, but scrolling normally (without pressing Ctrl) still often zooms! My home and office hardware are quite different, I doubt it is the hardware. But what do you need to know? – Aximili Jan 29 '14 at 3:45
  • 2
    It looks like the zooming issue is related to mouse scrolling freeware. I took a look at a tool I run called "WizMouse." The purpose of these tools is to allow scrolling windows without focusing on them. Settings can be changed in these to fix the problem. Resolutions: KatMouse (per nsx82): Add class: Chrome_WidgetWin_1, and under the settings tick option: "Window has scrolling wheel support?" (try checked first) WizMouse (per JoPa Mi): Uncheck "Enable mouse wheel for applications without mouse wheel support" ehiti.de/katmouse – Rachit Pathak Jan 29 '14 at 4:42
  • 1
    Wow how could you even think of that. I'm in the office, did what you said to my KatMouse and so far the scroll has been perfect! But I don't even have KatMouse at home... but may be a similar software, I'll check it at home. – Aximili Jan 31 '14 at 5:36
  • 1
    I think it solved the problem! I'm adding your comment that solved the problem into your answer, and accepting that. Thank you Rachit! – Aximili Feb 3 '14 at 3:00
  • I use KatMouse and your note about adding the class=Chrome_WidgetWin_1 fixed the problem for me. (I had to uncheck the box for "window has wheel scrolling support"). Note: I also had to click Apply in the KatMouse settings to see the effect (at first I thought my change didn't work. Luckily I noticed that before trying some more complicated solution ;) – dan May 25 '16 at 14:16
9

I've been annoyed by this for a long time, but when I searched most recently, I found a Chrome Extension that disables this Ctrl-scroll zoom behavior called No MouseWheel Zoom.

It worked fairly well, but didn't do exactly what I wanted (I wanted scrolling to continue as usual, even if I had pressed Ctrl. The extension just stopped scrolling and zooming altogether when Ctrl was pressed). So, I decided to make my own extension, which I just published yesterday. It converts Ctrl-scroll back into normal scrolling, and it's called ZoomToScroll.

Check these two extensions out and see if either one of them does what you want.

| improve this answer | |
  • I just tried it and can also confirm it works. thanks a lot! – programmer Apr 26 '17 at 8:04
0

Here's an AutoHotKey script that will remove the Ctrl+Wheel gesture from just Chrome and leave it for other appliations:

;Disable mouse wheel zooming in Chrome 
#IfWinActive, ahk_class Chrome_WidgetWin_1 
    ^WheelDown::return 
#IfWinActive, ahk_class Chrome_WidgetWin_1 
    ^WheelUp::return 
| improve this answer | |
0

Another workaround: this extension disables page zooming in general, unless/until enabled for specific tabs: https://chrome.google.com/webstore/detail/zoom-block/jmomepcgehgfoimapeoinphcloinjfpb

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.