15

I am having a nightmare right now, which is I'm stuck on logon screen of windows 7 professional. My password includes turkish characters and the keyboard layout changed somehow to english. And on logon screen I can't seem to find anywhere to change the keyboard layout. Hence I cannot logon to my windows, can't use my pc.

What should I do?

  • oh god, my father just told me the same thing happened to him. I need to fix this to him and he is in another continent. It's too bad that the solution is that complicated! – Jack Twain Apr 12 '15 at 9:06
5

I was stuck on the login screen on Windows Server 2003 while my keyboard language was accidentally changed to one that I don't have my password set in.

The solution was to use Alt + Shift to toggle between the keyboard languages.

  • In the upper left of the screen, you can see which keyboard language is currently selected. – Kevin Triplett Nov 23 '17 at 6:57
2

I had a similar problem. In the end I discovered that to change a keyboard layout, you can use the (left) CTRL-SHIFT combination. To see which layout it is set to, I use the on-screen keyboard.

  • ALT-SHIFT, not CTRL-SHIFT, and it can be either left or right -- this is on Windows 7 Enterprise – Kevin Triplett Nov 23 '17 at 6:59
2

In some versions of Windows you have the option to choose keyboard language right on the login screen, in the upper left corner of the screen. In your situation, you would have seen the letters EN inscribed in a square. If you click on it, a dropdown appears and you are able to choose the desired language.

  • This saved the day for me -- thanks!! – Kevin Triplett Nov 23 '17 at 6:35
1

One thing I can suggest is quickly looking up the Alt+xxx values for the characters to at least get you in the system. Once you have done that, you can then use the Control Panel method mentioned by @MOPTOH

  • In fact, for languages, you might find it easier to find here: symbolcodes.tlt.psu.edu/accents/codealt.html – bmgh1985 Jan 24 '14 at 8:46
  • I was very hopeful about this solution, but didn't work :/ – Tolga Evcimen Jan 24 '14 at 9:02
  • Are you using the Numpad or the numbers at the top of the keyboard? Also, if you have not used this method before, you need to ensure that you are holding down Alt until you have pressed all the numbers required (so you cant do Alt+1, Alt+2, Alt+8 to get Ç). If you are on a laptop and do not have a defined Numpad, often you will still have a NumLock key and when pressed, the NumPad buttons are mapped on the main keyboard – bmgh1985 Jan 24 '14 at 9:10
  • If you still have troubles, RegEdit may be a possibility. Will edit my answer to add this option in a minute (need to remember where these are in registry) – bmgh1985 Jan 24 '14 at 9:13
  • @MOPTOH has the better option though rather than editing the registry. Changing the password is probably the safer way to go – bmgh1985 Jan 24 '14 at 9:20
1

Eventually I ended up resetting my password with a third party software. Here is the link that I found, even though it is in Turkish I guess it is still really helpful. And here is the direct download link.

0

The possibilities depend on the version of Windows and possibly on how it's configured.

On my Windows 7 Enterprise at work, I don't have a way to change the keyboard layout, but there is a button at the bottom left to enable accessibility features. Select "On-Screen Keyboard", then hunt and peck. Depending on the layout you're stuck with, some characters may require you to first press "AltGr" (some languages use a different name) at the right of the space bar.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.