Have an ASUS RT-AC66R - we had set it up for our church and was working flawlessly. I was approached last sunday to say it was not connecting (2014-01-19). We had set it with the 2.5 and 5 Ghz connections and was fine. We tried to reset it there in place - which did not work. I said that I would bring it home and still cannot get to it to re-flash/reset/hard reset/etc.

I also had played with it initially and setup DD-WRT on it with no issue. However, I decided to run with the stock or ASUS' firmware with the initial rollout and was working fine.

Looking on the DD-WRT site, http://www.dd-wrt.com/wiki/index.php/Asus_RT-N66


It says, hold in the reset button until flashes slowly, but never does seem to get there.

I did grab a copy of Putty.. A copy of BitKinex.. I even grabbed the Utility from Asus.. Just cannot get there.

I pulled the feet covers off of the screws router and looking at the front of it, the right side front foot, has a white screw, but looks kind of odd like you can stick a paper clip in to reset the device. But, there does not seem to be anything that you can do with it.

I am trying to get the router reset and can only get the IP: (which of course is a bogus IP) and "unidentified network." I do have another wireless connection transmitting (Actiontec #: MI424WR) and is transmitting wirelessly as well - however when trying to connect to the Asus Router, I am using a direct connect cable and disabling the WLAN.

I setup DHCP as well a static IP - http://www.dd-wrt.com/wiki/index.php/Static_IP and disable the WLAN (I have a Dell Inspiron 1720 with a Broadcom 440x for the ethernet side).

Any Suggestions or ideas on how to fix this?

  • I wonder if the 30 30 30 works on that router - Press down on the reset button for 30 seconds, keep pressing in and unplug the router, and wait 30 seconds, then plugging it again.
    – Journeyman Geek
    Commented Jan 24, 2014 at 7:08
  • I have tried that too.. There is no connectivity to it.. It is like it is locked up. I will give it another try, however.
    – Leptonator
    Commented Jan 24, 2014 at 7:10
  • Erm. We might have a slight mismatch on what a Q&A site is - You may want to post your answer as an answer. And a question as a question. Think Jeopardy!
    – Journeyman Geek
    Commented Jan 26, 2014 at 6:48
  • @JourneymanGeek - I moved the original question body back up to the top. Hopefully, it flows better.
    – Leptonator
    Commented Jan 26, 2014 at 6:58
  • Post an answer as an answer, reword the question as a proper question. Its fine to self answer, but not to keep everything lumped together like that.
    – Journeyman Geek
    Commented Jan 26, 2014 at 7:00

4 Answers 4


Answer: Any suggestions listed/suggested here are just that - suggestions.

While the steps listed should be relatively safe, you assume any and all risks of "bricking" your router.

Go to the ASUS Page.. http://www.asus.com/us/Networking/RTAC66R/

Support Page.. http://www.asus.com/us/Networking/RTAC66R/#support

Drivers And Downloads.. http://www.asus.com/us/support/Download/11/2/RTAC66R/

Select Your OS.. I am using Win7 64-bit..

Under Utilities..

ASUS RT-AC66R Utility version

NOTE: You will come to find out that the AC66R is often listed with AC66U, the AC66U tools and firmware work fine with the AC66R

OS Supported: Win 2003 / Win XP / Win Vista / Win 7 / Win 8 Be sure in the description, it has the "Firmware Restoration" (when installed, start button/All Programs/ASUS Utility/RT-AC66U Wireless Router/Firmware Restoration)

http://dlcdnet.asus.com/pub/ASUS/wireless/RT-AC66R/UT_RT_AC66R_4275.zip Download, extract with an Unzip tool (like 7-Zip, WinRar, or PeaZip) and install

Also, under Firmware.. Grab a couple versions of the firmware - Probably not necessary, but just in case. :)

ASUS RT-AC66R Firmware Version Note: This does say it is Beta (at the time of this posting) http://dlcdnet.asus.com/pub/ASUS/wireless/RT-AC66R/FW_RT_AC66R_30043742239.zip

ASUS RT-AC66R Firmware Version http://dlcdnet.asus.com/pub/ASUS/wireless/RT-AC66R/FW_RT_AC66R_30043742050.zip

You may want to also download a couple of the PDFs for documentation as needed.

Googling, we do see that AC66R is supported under Tomato.. However, that is outside this discussion. :) I have used PolarCloud's firmware before and has worked fine on the devices I used it on.

But, because I have used DD-WRT in the past with success with an old LinkSys WRT54G..

Go to - http://www.dd-wrt.com/site/index

We do find the AC66R under AC66U in the "Router Database" on the DD-WRT site: http://www.dd-wrt.com/site/support/router-database

Type in 66u (the 66u is using the same firmware as the 66r).

Select the one for: Asus RT-AC66U

Download: dd-wrt-Asus_RT-AC66U.trx http://www.dd-wrt.com/routerdb/de/download/Asus/RT-AC66U/-/dd-wrt-Asus_RT-AC66U.trx/3899

Wiki http://www.dd-wrt.com/wiki/index.php/Main_Page

Good Information about the router.. http://www.dd-wrt.com/wiki/index.php/Asus_RT-N66U

There is a Wiki Page there too, which goes through quite a number of steps, intermediate steps to upgrade to Merlin, etc. As you will soon discover, I did not go through that.


Be sure that the Ethernet cable is in Ethernet connector of your laptop/desktop. In Networking, it will be helpful to temporarily disable wireless (sometimes called Wireless Zero - I just simply right-clicked and disabled the Wireless connection) on your laptop as well as it also wants to use IP: (by default, yours maybe different).

The other end is in one of the 1-4 ports and not in the WAN port.

In Windows, click the start button/All Programs/ASUS Utility/RT-AC66U Wireless Router/Firmware Restoration Program should come up.. Firmware Restoration

Click the browse button to locate the firmware you want to upload.. Browse to firmware to upload Click Open

Once you have loaded in the firmware Upload Click Upload Button

It will try to search out the router.. Searching for router

At this point, you will need to grab a pen (recommended), toothpick, or.. To press in the reset button and keep pressing it in.. Progression

And the instant you see the Firmware Restoration start uploading, release the reset button. NOTE: Since I completed this previously, there may be some variation in the screen prints here, but the process does remain the same

Cannot find router

NOTE: If you see the message: "The wireless router is not in rescue mode." You may have to try this process a couple times to get it there. I was not able to complete this the first time either. :) Be patient with holding down the reset. I know the DD-WRT forum and site is big on the 30-30-30 process/procedure and to be honest is good measure to be sure that folks hold in the reset enough time for the firmware to engage, and is also discussed in the Peacock document as well (see below). The ASUS router reset takes time to reset and using the firmware Restoration tool was the best way for me to see when the appropriate amount of time was needed to upload. Maybe I was missing it, I could not tell when the lights were slow or using the 30-30-30 process and those processes may work fine for other folks, but didn't work for the router I was re-setting.

The utility will show progress and complete. It will also restart the router.

System Recovery will complete. Complete

Wait for the router to start and the lights to come up. You should see: Power Port number: 1 or 2 or 3 or 4 2.4 Ghz 5 Ghz is flashing

You should be able to close the Firmware Restoration tool at this point.

Once router is up, you should be able to navigate with a web browser to and login. DD-WRT does immediately force you to set the login and password.

Since the firmware on coming up, does force a username/password change, you should not need this, but if you don't have the standard login/password to DD-WRT - if memory serves a reset on the router should reset the account as well, have a look on this page- http://www.dd-wrt.com/wiki/index.php/Hard_reset_or_30/30/30

Login and proceed as normal into the router.

HELPFUL LINKS AND BACKGROUND INFORMATION: I did watch the YouTube Video from "Charlie Tango" first and he said the same thing, he was able to go right to the DD-WRT version fo the firmware without having to go through the intermediate steps. http://www.youtube.com/watch?v=rG3fVNT18Pc

NOTE: Take the information from the Youtube video kind of like going to a buffet lunch. You are not going to like or need everything from the video. Pick and choose what you need and leave the rest. I ** WAS NOT ** able to use TELNET or clear NVRAM, putty, etc. All I could do is use the tool provided by ASUS to upload the firmware. The video does have informative components of it.. I was not able to get to the Web UI in the first place.

There are some helpful pages and such listed on the DD-WRT Wiki page. Some of the information can prove to be helpful: The Peacock Page - http://www.dd-wrt.com/phpBB2/viewtopic.php?t=51486 How to set a static IP - http://www.dd-wrt.com/wiki/index.php/Static_IP

  • You really should post the entire answer. I have to issue a downvote to the answer for this reason. When you make the changes to the answer it will be removed. I also don't see the actual solution in your question
    – Ramhound
    Commented Jan 25, 2014 at 20:02
  • Hopefully - this is better.
    – Leptonator
    Commented Jan 26, 2014 at 7:35

I tried the Asus recovery tool, this tool TFTP send the firmware but nothing happended. This didn't help(failed message ) I did this:

TURN Off the router with the button. Hold the WPS button and turn it on! Wait 15 seconden while holding and release WPS. WIFI led should blink again. is back!

  • THIS. This is the solution for this apparently common problem. I had the exact same scenario and after uploading the latest Merlin-WRT firmware via TFTP it still gave no love after reboot. However, the secret WPS button trick is what finally made the new firmware "take" and how the device reset to factory settings as @NiceTIP describes. Nice one.
    – Darf Nader
    Commented Jun 7, 2019 at 17:56

Just got off phone from ASUS Support.

To reset the router to factory default settings:

  1. Unplug the Modem to router cable. (Your router is now not physically connected to anything)
  2. Press and hold the small reset button on the back for 10 seconds. The power light will blink. Release the reset button.
  3. Wait until the power and wi-fi lights are solid color, mine are blue (takes a couple minutes)
  4. Plug the modem to router cable back in. Now you are connected to your modem.
  5. With your computer, on bottom right corner of the taskbar, check to ensure it can "see" that your router is available and transmitting. Your router's default name will be visible.
  6. Open a browser (IE or Firefox) and type "router.asus.com" in the address bar. You will now access the router's LOGIN page.
  7. If your router has a password printed on the sticker that's on the bottom or back of your router, then the username is "admin", the password is whatever is listed on your sticker. If you have no password on your router's paperwork or the router, then your user name AND password are "admin"

Once logged in to your router, you can change your settings as you wish.

Remember, first you are setting the router login information (name and password), the second setting is for the visible wi-fi name and wi-fi access password.

This way , if someone is sly enough to log into your wi-fi signal, they can't steal control of your router because you have a different router login.

Once I got this through my head, everything worked fine.

I hope this relieves someone's frustration.


I had several virtual Ethernet adapter network connections enabled for Virtual Box and VM Ware setup that caused the firmware recovery utility to fail with the error "The wireless router is not in rescue mode." By using Control Panel > Network and Internet > Network Connections and disabling all but the one wired Ethernet connection I plugged into the router, I was able to get the utility to update the firmware I downloaded from Asus.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .