0

What I'm trying to do is to maintain one git repository for my local WordPress development workflow. After much trial and error* I've managed to successfully install Ubuntu 12.04lts on my Windows 7 machine and setup xampp and WordPress. My idea is to be able to clone the vm for additional projects. (btw I have relatively very little experience in the *nix world, and am new to git as well - tho I've been using subversion (tortoiseSVN for years.)

So I have a Ubuntu 12.04lts guest running in windows 7. I have a myProject folder on windows with git repositories in sub directories (e.g myProjects/aProject}. I've installed xampp and WordPress 3.8 in the Ubuntu guest. I've shared the specific theme directory from my repository (e.g. myProjects/aProject/wp-content/themes/customtheme through virtualbox and it is usable on the guest as /media/sf_customtheme.

In the Ubuntu WordPress themes directory (/opt/lampp/htdocs/wordpress/wp-content/themes) I've created a symlink to /media/sf_customtheme (named customtheme.) If I click on the link it shows me the theme files.

However, when I log into WP and go to Appearance > Themes I get the following error: Notice: /opt/lampp/htdocs/wordpress/wp-content/themes/customtheme is not readable in /opt/lampp/htdocs/wordpress/wp-includes/theme.php on line 466

I've added myUserName to the vboxsf group and to the www-data group. Still no go. I suspect this must be some kind of permissions thing but I haven't been able to find any thing that helps. Oh yeah the shared folder is auto mounted.


*tried vagrant, tried Linux Mint in virtualbox, tried wp multisite - unable to get them working for me.

  • Vagrant is the perfect solution here, what wasn't working? – spuder Jan 24 '14 at 16:40
0

If it's just for development purposes, you can try opening the permissions of `/media/sf_customtheme/' to being completely open. This is not recommended for a production environment though.

To do this, on the Ubuntu guest just run sudo chmod 777 /media/sf_customtheme/.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.