0

I have recently bought and built a new PC: Windows 8 Enterprise x64, and Gigabyte GA-Z87-HD3 motherboard. Now, everything is put together and installed, I am facing only one problem.

I own an Adata Nobility NH13 external hard disk drive which is USB 3.0. When I plug it into any USB 3.0 port using a USB 3.0 cable, the drive does not show up in “My Computer,” nor in “Device Manager,” regardless of whether I use the Front or Rear USB 3.0 ports.

The USB 2.0 ports work just fine with it but what is the point in having a USB 3.0 device if you don’t use it the way you should?

If I plug USB 2.0 devices into the USB 3.0 ports, they work great, and if I connect the external hard disk drive with a USB 2.0 cable it does work.

Now, the first thing you would think is that the USB 3.0 drivers are missing, but in the Device Manager, under "USB Controllers", there is an entry for the "Intel(R) USB 3.0 eXtensible Host Controller-0100 (Microsoft)".

If anyone has any suggestions, any help is greatly appreciated.

  • Do you have any other USB 3.0 devices you can try? – Ramhound Jan 24 '14 at 18:11
  • @Ramhound sadly no, but it works just fine everywhere else... When I plug it into the usb3 port on my laptop it works just fine.. – Dino Prašo Jan 24 '14 at 18:13
  • I own an Adata Nobility NH13 for a while. It doesn't work on usb3 port. I just tried Toshiba CANVIO ALU and it works perfectly. Tried upgrading PCI driver and it says it's up to date. PC is IdeaCentre Lenovo. – user441101 Apr 25 '15 at 9:17
  • I've had similar and it was a driver issue, or a driver conflict issue... – Dave Dec 8 '17 at 16:35
  • 1
0

Try my answer. It's possible that the iusb3hcs (Intel(R) USB 3.0 Host Controller Switch Driver) part of the Intel driver is not installed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.