1

I've just recently reboot my server to find out an memory issue. The system just hang up at POST screen with code B2 just before booting the os, and I cannot open BIOS setup either. I've did some search and according to the manual the B2 state is 'Console Output/Input devices/Console initialization and Load Option ROM (VGA, RAID, parallel ports, serial ports……)'

refer: http://www.tomshardware.com/forum/321881-30-system-boot-error

Then I unplugged both PCI-E and USB device one by one and reboot to test. After I unplugged the last device this problem still remains.

The board is new and I did not change anything before this issue occurs, so I really have no idea about it.

2

Just spent countless hours with this issue on a Supermicro X9Dai motherboard. After playing around with the Clover EFI bootloader, all of a sudden the motherboard got stuck on POST, with the B2 status code. I could not get into either the BIOS nor the "Select boot device" screen. This made it impossible to flash a new bios or clear the NVRAM, which seems to be the main issue in my case.

After a bit of Googling, I came across the SuperMicro UEFI BIOS Recovery guide and it worked! This basically lets you boot into a BIOS recovery mode using a USB dongle and a latest BIOS file. Here's the steps:

  1. Using your laptop or spare pc, create a bootable FreeDOS USB dongle
  2. Download the latest bios from your motherboard's website. In my case (X9Dai) there is a link "Update Your BIOS" on the motherboard's page.
  3. Create a folder in the USB dongle and extract the BIOS files to the folder. Name the folder something easy like "BIOS" so you can "cd" into it later.
  4. Leaving all the files in the new folder, make a copy of the BIOS file to the root of the USB dongle (/) and rename it to "Super.ROM" (case sensitive!). The bios file is the largest (about 16mb), named something like "X9DAi5.XXX".
  5. Now insert the dongle in the X9Dai motherboard, and as soon as the keyboard powers up, hit CTRL+Home until it does two short beeps. It's a distinctive beep, so you'll know. Then wait and see if the BIOS comes in to "APTIO Recovery mode". I had to do this a couple of times to actually get in, not sure why. From here you can set "Reset NVRAM" enabled and "Proceed with Flash Update". There is also an option to "Reset Main Blocks" (something similar), I also enabled that.
  6. When done, you'll reboot and should be able to boot again to the FreeDOS USB!
  7. (MAY BE OPTIONAL) When booted on the FreeDOS USB, I "cd" into the BIOS folder and re-flashed the BIOS using the "AMI.BAT BIOSFileName.###" command. I'm not sure if this helped, but my BIOS was out of date anyway so I did it.

Important: When flashing the BIOS WAIT UNTIL THE DOS PROMPT SHOWS UP AGAIN, ONLY THEN IT'S COMPLETE. After flashing the BIOS, I powered the PC off, disconnected power, removed motherboard battery, cleared CMOS, and put everything back together. Then booted it up, got into bios, Loaded Defaults, saved, and reboot.

Hopefully this will save someone not going through hell like I have.

0

I guess the OP has sorted their problem one way or the other by now, but just to add that I have had this issue with a 6027R-TRF Superserver (Supermicro X9DRi3 system board) and I suspect it's because the UEFI boot options NVRAM has a bad or corrupt entry - this seems to make the system board freeze at 'B2', but I don't think it's actually the B2 test phase causing the problem.

I have tried clearing the CMOS RAM (by leaving out the coin cell overnight and also by shorting the clear CMOS solder pads), but I think this does not clear the UEFI NVRAM. The board also ignores the CTRL-HOME trick for an emergency BIOS flash/CMOS clear.

I suspect the root cause is too much editing of the UEFI boot options through the BIOS setup page - I have been working on various combinations of boot devices in a lab test environment and was deleting/recreating boot options several times an hour; on occasions, changes would not appear until I did a save/reboot, sometimes not at all, and sometimes the same option would appear in multiple boot slots, so I think management/editing of the UEFI data is buggy, leading to an accumulative error that eventually causes the POST process to hang.

Supermicro have agreed a board RMA with advanced replacement (the server is only about a month old).

0

If your RAID is a two-drive mirror, try removing a drive, resetting CMOS by removing the battery and shorting the contacts, and switching the machine to boot in Legacy Boot Mode using AHCI.

I encountered this problem when my board was configured to use the onboard Intel-based RAID in a two-drive mirror. In my experience, the onboard RAID has been unreliable if you are trying to boot the OS on the array.

0

My fix for B2 stuck boot for Supermicro X9DR3-F after bad power off:

1) Power off, detach all PCI-e & USB devices (except for keyboard), attach monitor to BMC (built-in VGA)
2) Reset CMOS with both battery and jumper
2) Wait for POST to begin and hit Del, 'Entering setup' should appear
3) Wait for PXE OpROM initializing and hit Ctrl+S to enter PXE setup
4) Exit Intel Boot agent setup and wait for BIOS setup
5) Load defaults, save and reset.

Now you should be able to enter BIOS setup or start OS.

Not the answer you're looking for? Browse other questions tagged or ask your own question.