1

I have recently purchased and installed a new battery for my Mid 2009 13 inch Macbook Pro but have not been able to turn on the laptop without the power supply since the new battery has been installed. The system report shows that the battery is installed but that it is not charging even though the battery is not at full capacity (83%).

Has anyone experienced a similar issue before? Does anyone know any fixes?

I cannot locate the disks that came with my MBP at the moment so I was also wondering if there was another way to access Apple Hardware Test (AHT)?

Thank you for any and all help!

4
  • Is this a third party battery? Or is it an OEM battery? Is it not possible to contact the seller for an exchange? Because to me it sounds like a defective battery.
    – imtheman
    Jan 25, 2014 at 19:32
  • This is the battery i purchased: amazon.com/gp/product/B009650Q40/ref=ox_ya_os_product But it was from a different vendor than the one that is currently listed. I can contact them and ask if they will exchange but I was wondering if there was anything for me to try before I returned it
    – wilco
    Jan 25, 2014 at 19:42
  • Try resetting your pram
    – spuder
    Jan 25, 2014 at 20:05
  • How do I do that? I believe I reset my SMC by removing the battery and holding the power
    – wilco
    Jan 25, 2014 at 20:08

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.