I want to share my lan internet connection over my hosted network. But it's being failed due to An error occurred while Internet Connection Sharing was being enabled...

I found this post but all the services mentioned there are running and windows firewall is on too.

Method 1: May be that, not all the services that run Internet Connection Sharing (ICS) are enabled. I’d suggest you to make sure the below dependency services are enabled.
Refer the following steps:
a. Click Start, Run, type services.msc, and click OK.
b. To enable a service, find it, double click it.
c. Make sure its startup Type is set to Automatic and service status to be started and click OK.

All the following services must be configured in order to use ICS:
a. Application Layer Gateway Service
b. Network Connections
c. Network Location Awareness (NLA)
d. Plug And Play
e. Remote Access Auto Connection Manager
f. Remote Access Connection Manager
g. Remote Procedure Call (RPC)
h. Telephony

After verifying and/or configuring Automatic startup for each of these services, close the Services window and restart the computer before attempting again to enable ICS.
You may refer: Using ICS (Internet Connection Sharing) http://windows.microsoft.com/en-us/windows7/Using-ICS-Internet-Connection-Sharing

Method 2: Based on my online research, the issue seems to occur on computers that have Windows Firewall disabled. Windows Firewall service has to be running even if you’re using another antivirus and firewall program on your computer. I’d recommend you to check for the status of the “Windows Firewall” service and set it to “Automatic”.
Follow these steps:
a. Click “Start”.
b. Type “services.msc” in the Start search box and hit “Enter”.
c. Right-click “Windows Firewall” and click “Properties”.
d. In the “General” tab, select “Automatic” under the “Startup type”.
e. Click “Start” to start the service.
f. Click “Apply” and “OK”. Restart the computer and check if the issue gets fixed.

How can I diagnose it?

  • 2
    I've inserted your linked data into your question, please don't use links in this way, if the link breaks your question becomes way too broad to stay open. – Tog Feb 2 '14 at 10:59

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.